Roundcube plugins: Soap Error: Forbidden

Discussion in 'Plugins/Modules/Addons' started by yalsicor, Nov 4, 2015.

  1. yalsicor

    yalsicor New Member


    I installed the ispConfig Plugins in roundcube as in this tutorial:

    I configured an Remote User in ISPConfig and ticked the necessary permissions. In Roundcube Settings I get the Soap Error: Forbidden. I tried it with another User and Password but still no luck. I even gave the RemoteUser all the permissions in ISPConfig to check weather I forgot some. Still same Error. It seems to connect to the soap_url fine though (no could not connect to host Error).

    Did I miss something?
  2. yalsicor

    yalsicor New Member

    Here is some more information.

    I'm running a Debian Jessie, Roundcube is installed and working fine. I can change settings in ISPConfig. But I cant change Settings like password or autoreply from Roundcube.

    Here is my ispconfig3_account
    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'roundcube-remote-user';
    $rcmail_config['remote_soap_pass'] = 'password';
    $rcmail_config['soap_url'] = 'https://domain:port/remote/';
    I am using a self-signed certificate and the domain matches the one in the certificate. I double checked remote User and password several times.

    These are the plugins I activated in Roundcube:
    $config['plugins'] = array("jqueryui", "ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter", "ispconfig3_forward", "ispconfig3_wblist");
    The apache access.log tells for trying to change something in Roundcube settings:
    [09/Nov/2015:15:52:52 +0100] "POST /remote/index.php HTTP/1.1" 200 5246 "-" "PHP-SOAP/5.6.14-0+deb8u1"
    [09/Nov/2015:15:52:52 +0100] "POST /remote/index.php HTTP/1.1" 200 4782 "-" "PHP-SOAP/5.6.14-0+deb8u1"
    [09/Nov/2015:15:52:52 +0100] "POST /remote/index.php HTTP/1.1" 200 917 "-" "PHP-SOAP/5.6.14-0+deb8u1"
    [09/Nov/2015:15:52:52 +0100] "POST /remote/index.php HTTP/1.1" 403 499 "-" "PHP-SOAP/5.6.14-0+deb8u1"
    There is no trace of connection in ispconfig/auth.log.

    I cant figure out what is wrong. Any ideas what else to check?
    Last edited: Nov 9, 2015
  3. jeensg

    jeensg Member HowtoForge Supporter

    Having the same problem and not finding any hint what to have a look at. Please help :)
  4. yalsicor

    yalsicor New Member

    After lot of tinkering I found the problem: mod-evasive.
    Turned out after 2-3 requests it blocked further requests to the server. Disabled and everything works fine..
  5. scenic2

    scenic2 New Member

    Can you tell us what that means? Can you be more specific?
    Where should i check to find "mod-evasive" setting.

  6. yalsicor

    yalsicor New Member

    scenic2 likes this.
  7. scenic2

    scenic2 New Member

  8. yalsicor

    yalsicor New Member

    There was a mistake. Its
    a2enmod evasive 
    scenic2 likes this.
  9. M.Meintjes

    M.Meintjes New Member

    Not sure if there are still people facing this issue with mod_evasive but you can also just whitelist the IP in the mod_evasive config file:

    nano /etc/apache2/mods-enabled/evasive.conf
    and just add the following:

    DOSWhitelist        <IP ADDRESS HERE>
    Note that you should only use IP addresses without the subnet part. You can also use wildcards here:

    DOSWhitelist        123.234.*.*

Share This Page