SAMBA (Domaincontroller) Server For Small Workgroups With Ubuntu 5.10

Discussion in 'Server Operation' started by Dagur, Dec 11, 2005.

  1. Dagur

    Dagur New Member


    I went through the howto and I can see my server in windows but I can't access it. I get "The network path was not found" error. Any help?
  2. Dagur

    Dagur New Member

    oh and when I try it from an ubuntu computer I get a timeout.
    There's no firewall set up on the server machine (yet)
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Have a look in the logs under /var/log/samba and the syslog for errors.

    Have you entered the network name + IP of the server and the workstation(s) in the hosts file of your Samba server?

    What output do you get when you run this command as root on your samba server:

    smbclient -L localhost -U%
  4. rbelk

    rbelk New Member

    I am having a different error. When I try to connect the the domain I get the following error on my Windows PC.

    The following error occurred attempting to join the domain "HOME":
    Logon Failure: unknown user name or password.

    Don't you have to add accounts for the windows pc's also for domain logons to work?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to add an user account first (for the user, not the machine). It is decribed on this page at the top:

    No, not manually. If you join the domain with a windows PC, the machine account is created automatically by the add machine script defined in the samba.conf.
  6. rbelk

    rbelk New Member

    I copied this from the howto

    # Useradd scripts
    add user script = /usr/sbin/useradd -m %u
    delete user script = /usr/sbin/userdel -r %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    add user to group script = /usr/sbin/usernod -G %g %u
    add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
    idmap uid = 15000-20000
    idmap gid = 15000-20000

    Is the bold line correct? I don't have a command "/usr/sbin/usernod".
  7. Dagur

    Dagur New Member

    So I got everything to work. I can read/write in windows but I can only get read-only access in linux. I've tried changing the config but it doesn't seem to change anything. The files are marked as if they have root:root ownership.

    Help! :(
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    What do you mean with read only access from linux? The howto is for anabling Windows workstations to store their data on the samba server, its not an NFS howto for connecting linux workstations to the server.

    If your files are marked as root:root owner, then you used the wrong user in windows. You will have to create a new linux + samba user, the connect with this username and password from windows. Not with the Administrator user. The Administrator is the root user on linux, it is only used in the process of adding your workstation to the domain to authorize you once as admin.
  9. Dagur

    Dagur New Member

    I'm not sure you understand.

    I have both linux and windows computers connecting to the samba server. Like I said everything works fine on the windows computer (read+write, and i do login as a samba user) but on my linux computer I can only read (unless I use sudo).
    Last edited: Dec 31, 2005
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks more like a problem on your linux workstation. Which user do you sue to connect from your linux worksattion and wich program / command do you use, smbmount?
  11. Dagur

    Dagur New Member

    I put this in /etc/fstab

    // /home/dagur/server smbfs credentials=/home/dagur/.smbmount-dagur,rw

    and .smbmount-dagur contains the lines

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried to use smbmount manually on the commandline and set username and password as commandline parameters?
  13. Dagur

    Dagur New Member

    yeah, but I got the same result :-/
  14. ED_209

    ED_209 New Member

    Also went through the howto (, but at the part when I start the installation of samba with the command:
    "apt-get install samba samba-common samba-doc libcupsys2-gnutls10 libkrb53 winbind smbclient" I seem to miss the winbind-packet. Get the response (translated from Swedish):
    "Packet winbind is not avaiable, but another packet refers to it. This usually means that the packet is missing, is obsolete or is avaiable from other sorces.
    E: Packet winbind has no installationcandidate"

    Tried to google for an answer, but didn´t find any, can anyone here help me?
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your /etc/apt/sources.list as described here:

    The universe repository must be enabled. Then run the commands:

    apt-get update
    apt-get upgrade

    and try to install samba + winbind again.

    apt-get install samba samba-common samba-doc libcupsys2-gnutls10 libkrb53 winbind smbclient
  16. tuxedotron

    tuxedotron New Member

    user password control

    Hi, thanks for the great tutorial! I set up everything except cups, and have been able to connect to my ubuntu domain controller using roaming profiles, it's very cool!

    I was wondering, is there a way for users to change their own passwords? Or does the administrator have to do that manually?

Share This Page