Seems [SOLVED] Mailman - list working, but no cgi-bin/mailman/admin URL

Discussion in 'Installation/Configuration' started by pongraczi, May 3, 2017.

  1. pongraczi

    pongraczi Member

    I just created some mailman email lists, which seemed fine during the creation. I also got emails about the new lists.
    When I tried to access to the fresh mailman URL I got via emails, I got
    ERROR 404 - Not Found!
    The following error occurred:
    The requested URL was not found on this server.
    Please check the URL or contact the webmaster.​
    Funny, I am the webmaster :)))))
    So, I checked the domain, it has cgi support ON, but no way to access to the mailman.
    I also tried to access via the server name, no luck.
    I found some older posts about mailman here, but not really relevant I guess, because it seems installed correctly and ispconfig created and integrated into postfix etc.
    Only problem it seems with the web access of the mailman.
    Any hints, what to check?
    Apache configs do not contain mailman relevant sections/settings, only lead is the enabled /etc/apache2/conf-enabled/mailman.conf which linked to /etc/mailman/apache.conf (which should work).
    In the apache error log I can see this:
    [cgi:error] [pid 1838] [client X.X.X.X:45176] script not found or unable to stat: /var/www/clients/client3/web11/cgi-bin/mailman
    The situation is that, cgi-bin exists, but something weird:
    # ls /var/www/clients/client3/web11/cgi-bin -al
    ls: cannot access: there is no file or directory (translated back to English)
    összesen 8
    drwxr-xr-x 2 web11 client3 4096 ápr 27 22:15 .
    drwxr-xr-x 9 root root 4096 ápr 27 22:15 ..
  2. pongraczi

    pongraczi Member

    One step closer:
    in the log (/var/log/apache2/suexec.log), I can see this:
    uid: (20012/web20) gid: (20001/client0) cmd: confirm
    [2017-05-03 22:28:52]: command not in docroot (/usr/lib/cgi-bin/mailman/confirm)​
    After playing around with several settings, I got a solution. Steps:
    • cp /var/lib/mailman/cgi-bin/* /var/www/DOMAIN.TLD/cgi-bin/mailman
      Copy necessary files into place
    • chown list:list /var/www/DOMAIN.TLD/cgi-bin/mailman/*
      Owner set to mailman list user
    • chmod 2775 /var/www/DOMAIN.TLD/cgi-bin/mailman/*
      Group set when execute bit on execution
    • Remove the suExec from the DOMAIN.TLD -> this was tricky, because even I deleted the flag from the ISPC domain setup, the vhos config file remained intact, so, I had to comment out manually and restart apache.
    Now I have a working mailman setup: list is working, webUI is working too.
  3. pongraczi

    pongraczi Member

    Please note: this could be a side effect of this PEBCAK, so, only SuExec could be necessary.

Share This Page