Server Setup Help Please

Discussion in 'Installation/Configuration' started by sapient, Oct 15, 2005.

  1. sapient

    sapient New Member

    Ok, just want to mention right off the bat that I think that ISPConfig is going to be great as soon as I can actually get it to work :D . I have some experience in configuring nameservers but obviously not enough- becuase I have been having problems getting this server to resolve. Allow me to just spill as many details as I can and hope that you can help me out.

    Debian setup following all tutorial steps-,

    Using cable internet access - behind a router (which I have been set and changed nearly every possible setting)- lan is comprised of server and personal pc's. I have set server out in DMZ, and have tried port-forwarding. Here is what I can get from

    I can access ISPConfig from local address 192.168.*.*:81... it works except I am experiencing the same problem as multiple others have had (images not displaying). I have setup A records for www, server1,

    server seems to time out if I try to ping it or check for SOA records... what can I do to fix this frustrating problem :eek: (I feel like I am close to getting this working, just need a little shove).
  2. falko

    falko Super Moderator Howtoforge Staff

    You have to use the same URL as in /home/admispconfig/ispconfig/ to access your ISPConfig, then the images will display.

    Do you try to ping/check from the internet? Might be a firewall problem. For DNS, you have to forward port 53 to your ISPConfig server to be able to make DNS lookups. Which ports do you have forwarded on your router to your ISPConfig box?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your ISP maybe block some ports to prevent that his clients are hosting servers at home?
  4. themachine

    themachine New Member HowtoForge Supporter

    ISPs... bleh

    Do you have your domain registered as its own name server?

    Running dig looks wrong...

    # dig +trace

    com. 172800 IN NS A.GTLD-SERVERS.NET.
    com. 172800 IN NS B.GTLD-SERVERS.NET.
    com. 172800 IN NS C.GTLD-SERVERS.NET.
    com. 172800 IN NS D.GTLD-SERVERS.NET.
    com. 172800 IN NS E.GTLD-SERVERS.NET.
    com. 172800 IN NS F.GTLD-SERVERS.NET.
    com. 172800 IN NS G.GTLD-SERVERS.NET.
    com. 172800 IN NS H.GTLD-SERVERS.NET.
    com. 172800 IN NS I.GTLD-SERVERS.NET.
    com. 172800 IN NS J.GTLD-SERVERS.NET.
    com. 172800 IN NS K.GTLD-SERVERS.NET.
    com. 172800 IN NS L.GTLD-SERVERS.NET.
    com. 172800 IN NS M.GTLD-SERVERS.NET.
    ;; Received 492 bytes from in 33 ms 172800 IN NS 172800 IN NS
    ;; Received 108 bytes from in 43 ms

    => and then it hangs here <=

    dig: Couldn't find server '': Temporary failure in name resolution

    Everything digs back to '' and then tries to resolve '' and '' from your nameserver and fails.

    Where as if you look at the difference with my domain...

    # dig +trace

    ;; Received 436 bytes from in 3 ms

    org. 172800 IN NS TLD1.ULTRADNS.NET.
    org. 172800 IN NS TLD2.ULTRADNS.NET.
    org. 172800 IN NS
    org. 172800 IN NS
    org. 172800 IN NS TLD5.ULTRADNS.INFO.
    org. 172800 IN NS TLD6.ULTRADNS.CO.UK.
    ;; Received 291 bytes from in 42 ms 86400 IN NS 86400 IN NS
    ;; Received 101 bytes from in 63 ms 86400 IN A 86400 IN NS 86400 IN NS
    ;; Received 101 bytes from in 0 ms

    I would check that port 53 is accessible from outside your network. If you have access to a webserver or have a friend just run the command:

    # nslookup w.x.y.z

    w.x.y.z being the IP Address of your home/router/IP that your domain is suppose to be listening on. this way your are specifically querying your server at w.x.y.z and not attempting to resolve across the internet.

    # nmap -p 53

    Starting nmap 3.81 ( ) at 2005-10-15 09:39 CDT
    Interesting ports on <dnsname_removed> (
    53/tcp filtered domain

    Nmap finished: 1 IP address (1 host up) scanned in 0.632 seconds


    # nslookup
    ;; connection timed out; no servers could be reached

    # nslookup
    ;; connection timed out; no servers could be reached

    You've got something going on there on your side...
  5. sapient

    sapient New Member

    Thank you for the replies (Its early morning here now so just now reading them). I am port-forwarding port 53, 80, 81, 22, 20 to my server.. so everything from the internet hits my router at .157 - then it forwards all those to my internal server ip.

    I can ping my ip from the internet (of course that is just pinging the router):
    but my domain name cannot be resolved to ip:
    My server's name is, (secondary dns) is the same machine right now. If I goto I can bring up the control panel (but still the images are gone and it sometimes says it cannot resolve

    Using I registerd my domain and set the nameservers to & both pointing to my public ip *.*.*.157.

    There is part of my i notice now that it shows - , I need to change that to (right?)

    I hope not- I will continue to investigate, but please dont give up on me yet! :D I really would like to use this setup,
  6. sapient

    sapient New Member


    Also I just tried this ping from www\.dns\.com
    Does that mean some of my changes to the router are working??? :confused:
    [edit] And now that i changed the I do see the images properly!!! Thanks!! I am so close now I can taste it!-- now for the ip/dns problems[/edit]
    Last edited: Oct 15, 2005
  7. falko

    falko Super Moderator Howtoforge Staff

    This seems to be the chicken - egg problem. You want to resolve (its own domain). But how do other name server know then who is if only has the answer?
    I think you need another nameserver for, and then you can use as nameserver for other domains.
  8. sapient

    sapient New Member

    You guys are great!

    Thanks for all the help- especially for the quick replies, manning this forum full of newbs like me is a full time job- and now that I got it working I hope to start participating and helping you all out.

    If you goto it brings up the website- which is the nice clean default setup by ispconfig, and if you goto :81 for or just it brings up the login..

    Under the ispconfig control panel I have a domain setup: with A(host) records for www and such. Also under server settings I have Hostname: server1 Domain with IP and Netmask both my local ip /netmask

    I did discover that Bind had failed due to a duplicate entry (most likely due to my tinkering). After removing the duplicate entry in etc/bind/named.conf I was able to bind restart and BAM! - everything started showing up online!!!


Share This Page