setting up ftp access for clients

Discussion in 'Installation/Configuration' started by Jrdgames, Feb 23, 2006.

  1. New Member

    OK, did that but had some problems with the ftp server. It wouldn't start, although '#/etc/init.d/proftpd start' gave positive feedback ('starting proftpd...').

    Anyway, I sorted that one out with changing the configuration back.

    Now the new problem:
    When I have the firewall from ISPConfig running, my ftp server is "not really" reachable. So, this means, I can run gFTP on it, and it gives no negative feedback. It connects to the server fine, but I do not get a directory listing. The last line of the ftp log in procedure is:
    So, I thought, maybe the firewall is blocking the passive ports of ftp, but how come it worked before with the same firewall and ftp server settings? Did I change something that I'm unaware of? Why could this be? What are the passive ports of ftp? Should I open them in the firewall?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig firewall has not changed since version 2.0.0
  3. New Member

    Sorry, I have to correct myself. I didn't test it before. I just remembered it wrong. So, it's not working with the firewall on. :(
  4. falko

    falko Super Moderator Howtoforge Staff

    Did you try both active and passive mode in your FTP client? Is port 21 open in your firewall? You might also have to open port 20.

Share This Page