Sirous problems after updating Ispconfig 3.1 to 3.2

Discussion in 'ISPConfig 3 Priority Support' started by virk6, Nov 14, 2020.

  1. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You will have the same problem unless you uninstall ISPConfig completely and delete any leftovers manually. But this could/would mean losing all your data. If you follow the steps like I told you the issue should be fixed.
    till likes this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A reinstall makes not much sense in this case, as you will lose the whole setup and data. First, find out which database your system is using as @Th0m suggested several times, and then run the SQL files that were mentioned already in that database using phpmyadmin.

    if this does not work, then you can still roll back to your old ispconfig version by using the backup that was made during update (if you selected to do a backup when the updater asked you), you can find that backup in a subfolder of /var/backup, it contains the ispconfig database, the /usr/local/ispconfig folder and the /etc folder. But before you try to restore the backup, make a backup of your current ispconfig database, the /etc/ folder and /usr/local/ispconfig folder.

    And as @Th0m suggested, it might be a good idea to contact Florian from ISPConfig business support here to fix this, if you are unsure how to do it yourself.
    virk6 likes this.
  3. virk6

    virk6 Member HowtoForge Supporter

    I made all the modifications but sadly no base works:
    with the dbispconfig or dbispconfig2 base I still have the same problem, namely
    Unknown column 'server_php_id' in 'field list'
    Unable to create a site in the Ispconfig dashboard.
    I've spent all day on it and am considering backing up dbispconfig2 and reinstalling Ispconfig.
    What precautions should I take?
    thanks for your advices
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In one of your earlier posts, you showed that phpmyadmin complained that this column exists already. It can not be the case that ispconfig says that the column is missing and phpmyadmin says its's there when you try to add it, the only logical solution for this problem is that you did not run the SQL file in the right database.

    This will not help you, at least if you want to be able to manage existing sites and mail accounts in the future. The ispconfig installation is perfectly fine, your problem is the database structure. The changes that are needed in the database for 3.2 seem not to be installed.
    Th0m likes this.
  5. virk6

    virk6 Member HowtoForge Supporter

    Hello everyone !

    Thank you to all of you who have tried to bring your enlightenment to me and I am grateful for it.
    Finally the problem was solved this morning by restoring the two ispconfig databases then I reapplied
    the hot procedure to know
    tar xvfz ISPConfig-3.2.tar.gz
    cd ispconfig3_install / install
    php -q update.php

    My problem is solved but the two databases dbispconfig and dbispconfig2 remain.
    In the Ispconfig configuration files it is the dbispconfig2 database which is present whereas before there were both (dbispconfig and dbispconfig2)

    One last question: can I replace or rename dbispconfig2 to dbispconfig?
    It will be enough to put the right base in the configuration files Ispconfig?

  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Yes, you could rename dbispconfig to dbispconfig-unused (to save it just for sure) and rename dbispconfig2 to dbispconfig. Make sure to change it in the config files and then reconfigure services.
  7. virk6

    virk6 Member HowtoForge Supporter

    Ok I will do it.
    Thank you.

Share This Page