[SLOVED]ispconfig 3, debian 11, php 5.6 and mysql extensions

Discussion in 'Installation/Configuration' started by gec, Feb 10, 2022.

  1. gec

    gec Member

    just to not mess something up...
    what exactly means "remove dotdeb from your system"? delete the dotdeb.list?
     
  2. gec

    gec Member

    ok. I've made a backup of and than deleted dotdeb.list file, and updated php.list
    i've done apt-get update and apt-get upgrade.
    got notice that i have a bunch of files that i can clean with apt autoremove - done that
    got also bunch of notices like
    Code:
    NOTICE: Not enabling PHP 5.6 FPM by default.
    NOTICE: To enable PHP 5.6 FPM in Apache2 do:
    NOTICE: a2enmod proxy_fcgi setenvif
    NOTICE: a2enconf php5.6-fpm
    NOTICE: You are seeing this message because you have apache2 package installed.
    
    for every version of php on my system
    tried to do ispconfig_update.sh --force (cause i'm all ready on last version) but now I get PHP Curl module is missing so update can not continue.
    My guess is that Curl is just first in the line of missing modules.
    I've installed curl using apt-get install php7.0-curl php7.1-curl ... for all the php versions in my /etc/php/ folder but still get missing Curl error

    not sure what i'm doing wrong
     
  3. ahrasis

    ahrasis Well-Known Member

    Did you run apt-get install php-curl as well? Did you run phpenmod for the module? Did you restart your each php fpm version?

    Plus, ensure you did not change default php in any of the process.
     
  4. gec

    gec Member

    thx ahrasis.
    i did run apt-get install php-curl. did not do the rest. I was under impression that module gets enabled automatically with installation.
    will try your advice
     
  5. gec

    gec Member

    did the phpenmod an restarted all the fpm.
    still same "PHP Curl Module is missing." BUT!!
    i've noticed that i've missed one Warning:
    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/curl.so' - /usr/lib/php/20151012/curl.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
    I've checked this location and curl.so is missing from that folder. but there are newer folders in /usr/lib/php/ that do have curl.so. Why does the installer use this old folder?
     
  6. gec

    gec Member

    and my phpmyadmin died but i can probably reinstall it
     
    Last edited: Feb 11, 2022
  7. ahrasis

    ahrasis Well-Known Member

    Yes. Normally you don't need phpenmod if the package is installable via apt-get.

    If you did that all but missing curl.so in some, you may need to reinstall curl for that php version.

    I am not sure why you PMA died.
     
  8. Aeon112

    Aeon112 New Member

    Try reinstall php curl, when it works do a


    Code:
    update-alternatives --set php /usr/bin/php7.4
    update-alternatives --set php-cgi /usr/bin/php-cgi7.4
    update-alternatives --set phar /usr/bin/phar7.4
    update-alternatives --set phar.phar /usr/bin/phar.phar7.4
    update-alternatives --set phpize /usr/bin/phpize7.4
    update-alternatives --set php-config /usr/bin/php-config7.4
    update-alternatives --set php-cgi-bin /usr/lib/cgi-bin/php7.4
    update-alternatives --set php-fpm.sock /run/php/php7.4-fpm.sock
    then run ispconfig update.php, don‘t forget to adjust the php configuration in ispconfig webinterface After update.
     
    Jesse Norell likes this.
  9. gec

    gec Member

    so update alternatives only for php7.4?
     
  10. Aeon112

    Aeon112 New Member

    Yes, the sury repo Sets php8.0 as Standard in Debian, Ispconfig won‘t work with php8. Debian bullseye ships with php7.4 as default thats why you schould exec this commands.
     
  11. gec

    gec Member

  12. Aeon112

    Aeon112 New Member

    I think this is not possible, correct me when i am wrong.
     
  13. gec

    gec Member

    i got this errors:
    update-alternatives: using /usr/bin/phar7.4 to provide /usr/bin/phar (phar) in manual mode
    update-alternatives: warning: not replacing /usr/bin/phar with a link
    update-alternatives: warning: not replacing /usr/share/man/man1/phar.1.gz with a link

    update-alternatives: error: alternative /usr/bin/phpize7.4 for phpize not registered; not setting

    update-alternatives: error: alternative /usr/bin/php-config7.4 for php-config not registered; not setting
     
  14. Aeon112

    Aeon112 New Member

    It's correct, you can ignore this "errors", the last two errors are because you have not installed the php-dev packages. php-dev packages are not important.
     
    gec likes this.
  15. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That directory is for php7.0 files, so installing the php7.0-curl package would provide that file. It was looking in that directory because you had the wrong php version in use, which you have now corrected, but you might still need that package if you use the old php7.0 on any sites.

    In apache you can set the default php interpreter to php-fpm using those a2enmod/a2enconf commands - be sure you a2enconf php7.4-fpm (not 5.6). Also a2dismod any mod_php versions you might have (or preferably, just uninstall those packages completely).
     
    gec likes this.
  16. gec

    gec Member

    Thx Jesse for the answer.
    Dou you as a ispconfig developer have a opinion on this https://www.howtoforge.com/communit...and-mysql-extensions.88411/page-2#post-432157 question?
     
  17. gec

    gec Member

    for now everything looks working, so i'll mark this thread solved.
    thx all for the help!
     
    Aeon112 likes this.

Share This Page