Slow response

Discussion in 'Installation/Configuration' started by Morons, May 22, 2007.

  1. cjc81

    cjc81 New Member


    Thanks so much for that! I have been searching high and low to find out how to do that. Appreciated =)
  2. cjc81

    cjc81 New Member

    Hey guys, i just checked the email headers of emails coming from my two servers running clamd. Apparently, after about 11am local time, the virus scan process failed.

    When i try to execute /home/admispconfig/ispconfig/tools/clamav/bin/clamdscan,

    i keep geeting
    Anyone knows what happened? Did freshclam updated something that causes this to fail?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to restart your clamd daemon.
  4. cjc81

    cjc81 New Member

    Hi Sir,

    Tried that. But apparently, the daemon closes itself after a couple of seconds.
  5. XPinG

    XPinG New Member

    While configuring my clamd I had this problem and it's why Iprefered to turn on the log, I had

    ERROR: Socket file /home/admispconfig/ispconfig/temp/clamd is in use by another process.
    I think this is because the previous clamd process was not fully shut so, stoped the clamd
    service clamd stop
    delete the tmp file
    rm -f /home/admispconfig/ispconfig/temp/clamd
    and then run again clamd
    service clamd start
    I watched again in my log (according to my previous posted config)

    tail -f /var/log/clamd.log
    and the error stops apearing I tried then the connection from clamdscan
    and the error disapear :), hope this help you
  6. cjc81

    cjc81 New Member

    Thanks again. You helped me solve my issue once again =)
  7. mlz

    mlz New Member

    The one issue I've always had with clamd is that during an update it sometimes hangs. I've advised the developers so many times I don't even bother. It would be nice if ISPConfig defaulted to clamd and showed the process in the status screen, however for right now anytime I'm having issues, I just do a ps ax | grep [c]lamd and see if it's hung...

    BTW, you can put the rpm /tmp/file in your init.d script and have it automagically kill it...
  8. kassie

    kassie New Member

    This is what get if i run this on my Ubuntu 7.0.4

    apt-get install clamav-daemon
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    clamav-base clamav-freshclam libclamav2 libgmp3c2
    Suggested packages:
    daemon clamav-docs
    Recommended packages:
    The following NEW packages will be installed:
    clamav-base clamav-daemon clamav-freshclam libclamav2 libgmp3c2
    0 upgraded, 5 newly installed, 0 to remove and 2 not upgraded.
    Need to get 10.4MB/10.9MB of archives.
    After unpacking 12.2MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Err feisty-security/universe clamav-base 0.90.2-0ubuntu1.1
    404 Not Found [IP: 80]
    Err feisty-security/universe libclamav2 0.90.2-0ubuntu1.1
    404 Not Found [IP: 80]
    Err feisty-security/universe clamav-freshclam 0.90.2-0ubuntu1.1
    404 Not Found [IP: 80]
    Err feisty-security/universe clamav-daemon 0.90.2-0ubuntu1.1
    404 Not Found [IP: 80]
    Failed to fetch 404 Not Found [IP: 82.211 .81.138 80]
    Failed to fetch
    v/libclamav2_0.90.2-0ubuntu1.1_i386.deb 404 Not Found [IP: 82.211 .81.138 80]
    Failed to fetch 404 Not Found [IP: 80]
    Failed to fetch 404 Not Found [IP: 82. 211.81.138 80]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
  9. Morons

    Morons Member

    apt-get maintenance

    Try the following solutions.
    apt-get update
    Otherwise browse ubuntu's web for correct /etc/apt/sources.list content, also refer to to get a good start sources file. Just remember those sources are normally localised and you might be some distance from it.
    If you edit /etc/apt/sources.list always run
    apt-get update
    and i can suggest
    apt-get upgrade
    as well.
  10. kassie

    kassie New Member

    Thanks Till,

    Now the previous command also worked
    apt-get install clamav-daemon

    Now I can get cracking with the rest...
  11. MTvermoes

    MTvermoes New Member

    CENTOS 5
    yum install clamd
    inside /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin
    change the CLAMSCAN line to
    inside /etc/clamd.conf check the line ScanMail
    ScanMail true
    inside /etc/freshclam.conf AND also in /home/admispconfig/ispconfig/tools/clamav/etc/freshclam.conf check NotifyClamd
    NotifyClamd /etc/clamd.conf
    Run :
    chkconfig clamd on
    Thats it.

    THX to prev Posters for hints in the right direction.

Share This Page