[SOLVED] DKIM not creating key pairs

Discussion in 'Installation/Configuration' started by DonniesCat, May 23, 2017.

  1. DonniesCat

    DonniesCat New Member


    I'm using ISPConfig 3.1.2 running on Debian Jessie

    I'm using Dovecot and the DKIM configuration is the following:
    system > server config > mail > DKIM path > /var/lib/amavis/dkim
    system > server config > mail > DKIM strength > 1024

    The problem I have is that whenever I go to:
    email > domain > mydomain.tld I click on DKIM and it shows the DKIM configuration for that domain (like the picture), but when I click on "Generate Key" it just does nothing. I've tried changing the selector for another string, but still does nothing, I can't save with DKIM enabled as it has not any private key written.

    I've also tried to generate with openssl a key pair and upload it to /var/lib/amavis/dkim, and copying with ctrl+x ctrl +v in the DKIM Private Key, and then I'm able to save the domain config, but when I go to the DNS of the domain, no DKIM record has been created automatically. (I haven't tried further actions with the manually generated key, as I want to do everything from the control panel).


    Thanks you so much :)
  2. concept21

    concept21 Active Member

    Check every error logs first.
  3. DonniesCat

    DonniesCat New Member

    I've looked all of them already and couldn't find any suspicious, which one do you want me to post?

    I just press the button and nothing happens, I don't even think it's calling any function.
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    did you disabled the php-function exec?
    DonniesCat likes this.
  5. DonniesCat

    DonniesCat New Member

    Yes, I did...
    That was the issue, I tried enabling the "exec" function and it worked.

    I added the DKIM, and after 1 minute I ran the mail-tester.com test and it detected the DKIM so I got the 10 out 10 mark :)

    Thanks you so much!

Share This Page