[SOLVED] open_basedir restriction in effect PROBLEM with adodb and smarty

Discussion in 'ISPConfig 3 Priority Support' started by Tomislav Aurednik, Oct 3, 2016.

  1. Hello! I'm trying to get a site working that needs adodb5 and smarty. The previus host send me this 2 frameworks and said to put them into /usr/share/fw_classes. But the page simply isn't loading. I added in sites -> options -> custom php.ini as i found on google for this error:

    open_basedir = "/usr/share/fw_classes:/var/www/clients/client22/web32/web:/var/www/clients/client22/web32/private:/var/www/clients/client22/web32/tmp:/var/www/ceveljc.si/web:/srv/www/ceveljc.si/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin"

    But I still get the error
    mod_fcgid: stderr: PHP Warning: include_once(): open_basedir restriction in effect. File(/usr/share/fw_classes/smarty3rc4/libs/Smarty.class.php) is not within the allowed path(s): (/var/www/clients/client22/web32/web:/var/www/clients/client22/web32/private:/var/www/clients/client22/web32/tmp:/var/www/ceveljc.si/web:/srv/www/ceveljc.si/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin)

    Does anyone have any expiriance with those 2 frameworks and can help me fix the problem?
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Custom php.ini is the wrong place for it. Simply add the /usr/share/fw_classes: to the open_basedir field in options.
    Tomislav Aurednik likes this.
  3. My bad... didn't see that field. Thanks! Now on to fixing the other errors.
  4. When I try to view the page a get only a browser error:
    The page you are trying to view can not be shown because it uses an invalid or unsupported form of compression.

    There are no errors in sites error log or viewing the browser console.
    Anyone any idea?
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Check your web server config. Might be that you are suffering from "double compression" (compressing contents two times, so not readable by browser).
    Tomislav Aurednik likes this.
  6. Thanks... it was a problem with compression. Just added zlib.output_compression = On to sites custom php.ini and it works.

Share This Page