[SOLVED]Problem permanently mounting NAS drive

Discussion in 'Installation/Configuration' started by Samo_slo, Jul 7, 2016.

  1. Samo_slo

    Samo_slo Member

    I'm running Ubuntu 14.04 server and i can't get my nas drive to mount at reboot. I created a credentials file with the login and password and i added this line in /etc/fstab.
    //NAS-NASNAME/vm /mnt/NAS/media cifs uid=1000,rw,noperm,noserverino,nogroup,rw,credentials=/root/credentials/NAS/media,iocharset=utf8 0 0
    Ok i really don't know what everything does but it worked on my old server.
    But after reboot i can mount my drive with "mount /mnt/NAS/media" with no problem.
    Any idea why it doesn't work?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the network is not up at the time the nas gets mounted. Try to add the _netboot option to the mount options. If this does not work, then add a command to mount the NAS in /etc/rc.local instead of configuring it in fstab as rc.local gets executed at the end of the boot process when the network is available.
    Samo_slo likes this.
  3. Samo_slo

    Samo_slo Member

    Thanks Till! I hade to leave the options without _netboot in /etc/fstab and added mount /mnt/NAS/media to /etc/rc.local and now it mounts!

Share This Page