[Solved] Sites suddenly not working after typical Ubuntu updates

Discussion in 'General' started by Xase, Nov 15, 2018.

  1. Xase

    Xase Member

    Edit: Running Ubuntu 18.04, and ISP Config 3.1.13
    I ran 'sudo apt update && sudo apt upgrade' yesterday on both servers and now, my servers are still functioning... however, all my pages are showing my "coming soon" page, and a lot of them are throwing this error

    Your connection is not private
    Attackers might be trying to steal your information from gethosting.today (for example, passwords, messages, or credit cards). Learn more
    Last edited: Nov 15, 2018
  2. Xase

    Xase Member

    To further elaborate, there doesn't appear to be any related information in the logs.
    I also didn't immediately reboot them either, but my location lost power this morning... not sure if it's related... but unlikely. It was the loss of power that drew our attention to the problem.
  3. Xase

    Xase Member

    So, directories seem to be intact, but not configured appropriately perhaps? Not sure about the SSL error I'm receiving on some of them. I'm assuming that's related to Let's Encrypt not being able to verify correct location for the domain via current config.
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is web server running on those hosts?
    You did not say what operating system, so just guessing here because you have apt-get.
    systemctl --state=failed
    to see if any services are not running.
    Xase likes this.
  5. Xase

    Xase Member

    Edited OP to reflect that info... I often forget that there are other Linux distributions that are used with this software. My bad :p

    [email protected]:~$ systemctl --state=failed
    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
  6. Xase

    Xase Member

    So. The only other thing I did, was to delete a site, create a new client, and reassign that site as belonging to the new client. All sites seem to be pointing to this one site, upon further examination. None of the assigned directories have changed... they just all seem to be pointing to ninjatest.site
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Possible reasons:

    a) You mixed up IP and * in the ipv4 field on the server, use either * or IP for all sites.
    b) the new site is the only one with SSL enabled on that server, so all non-ssl sites point to it when you access them with https instead of http.
    Xase likes this.
  8. Xase

    Xase Member

    @till That's a silly error, but an easy fix. It was your first suggestion that fixed it. Thanks for being awesome, and dealing with this obnoxious newbie that I am.

Share This Page