SSH User not working

Discussion in 'ISPConfig 3 Priority Support' started by olimortimer, May 18, 2014.

  1. olimortimer

    olimortimer Member


    I'm trying to setup a client on SSH, but it's not working.

    I've assigned the login against their account, and making sure I'm connecting with 'clientuser' as the username.

    The only option I've changed is 'Jailkit' under 'Chroot Shell'.

    I've rebooted the server, but still not allowing me to connect - it just says 'Permission denied', yet I know it's the correct username and password.

    I tried exactly the same, but without the 'Jailkit' option, and it works, yet obviously the user can access anything on the server.

    These are the lines for the user in question in '/etc/passwd';

    The file '/usr/sbin/jk_chrootsh' doesn't exist - I don't know if this is correct.

    Any ideas please?
  2. olimortimer

    olimortimer Member

    Oops, my mistake. Realised I chose not to install Jailkit during the ISPConfig install. Just installed it, then re-downloaded ISPConfig, ran the install/update.php file (choosing to reconfigure services), and it now works fine.

Share This Page