SSH User Permissions wrong?

Discussion in 'General' started by ochorocho, Nov 25, 2014.

  1. ochorocho

    ochorocho Member


    i just tried to setup a ssh account. it worked as expected.
    User is able to login and work on the web/-Folder which is fine.

    But in my case, i want the shell user to be able to create a .bashrc file and some other stuff in /var/www/clients/client1/web52/

    These permissions are set by ispconfig to a new webspace i created:
    drwxr-xr-x. 10 root root 4096 25. Nov 11:24 web52

    How can i make ISPConfig to set the username and group on that folder when created?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The permissions are correct, users may not add something directly in /var/www/clients/client1/web52/ as thats the web root and this folder has to be owned by root, if it would be owned by the ssh user that you crarted, then he would be able to take over your server and I guess that not what you want. The home directory of a user is /var/www/clients/client1/web52/home/username/ btw.
  3. ochorocho

    ochorocho Member

    Ok ... i have changed it from "none" to "Jailkit" and it does exactly what i wanted it to do.

    Is there a way to make this defuault value?

    Thanks Till, lightning fast response !
  4. ochorocho

    ochorocho Member

    ok ... note to myself: ISPConfig cant set defaults for admin user, but ISPConfig can set defaults for "normal" client users.

    Sorry Till for bothering.

    Thanks. Everything is working as expected.


Share This Page