SSL related problems

Discussion in 'Installation/Configuration' started by senzapaura, Dec 28, 2005.

  1. senzapaura

    senzapaura New Member

    Till, Thanks for the help.

    I have double checked my DNS record for my external domain name ( and made sure the external IP address and its A-Record is pointing to my router. This is a dumb router and it relays the messages to a Linux firewall running Astaro. I then checked my firewall to make sure it is sending all messages from that external IP address to the correct internal IP address of the web server that contains a Named Virtual Host for the external domain name. This includes HTTP and HTTPS services. Please remember this site is accessible externally using The web server’s internal name is amgsrv1 and the internal domain it is running on is I also double checked these settings. It is my understanding that the firewall uses the internal server name tied to the internal IP address to reroute the message. It is possible that this is a problem, is anyone else you know using Astaro? I have also double checked the virtual host file it appears to be correct. I obviously have an error someplace, but if my assumptions are correct I have exhausted my options for debugging this problem. It was originally generated (virtual host file)using ISPConfig. To expedite my testing I have made some manual changes to the file figuring when I get it working I can regenerate it with ISPConfig. I just do not know how to confirm these settings any further unless I had the ability to look inside the messages and confirm they are being sent properly. Would you agree that the problem appears not to be in the SSL certificate? Could you show me what an ISPConfig virtual host file should look like to make sure it is configured for a named domain? I think you are correct, but how do I make it use the domain name?
    Last edited: Feb 2, 2006
  2. senzapaura

    senzapaura New Member

    Is it possible that the new version of Apache 2 just released will fix this problem?
  3. falko

    falko Super Moderator ISPConfig Developer

    Well, it is possible, but I don't think your problem is caused by the Apache version. It must be some kind of misconfiguration.
  4. New Member

    PHP over SSL does not work

    Finally, I have sucessfully installed ISPConfig, but now I am having problems.

    My Setup:
    1 IP
    3 domain names (so far)

    I am hosting 3 sites so far and I would like PHP to work over SSL for all of them (or at least one). Do I have to put files into the ssl directory?

    I had a working site ( )

    But when I want to log in on (login is linked to https://...) I get the PHP source code of the page and not the HTML output of it. Also, I tried to open a test php file over but could not see the page at all, got a not found error. I put the phpinfo.php file in the root directory of /home/www/ and in /home/www/ . Both didn't work.

    I am confused. I turned on SSL in ISPConfig for that site, so I thought it should at least work for that one.
    Last edited: Apr 3, 2006
  5. New Member

    OK, figured it out now myself. I had to fill in the blanks under the SSL tab. Cool, even the email address is working :). Very nice tool. Thank you for providing it for free :)

    So, how do I get SSL to work for other domains with only that one ip address?
  6. falko

    falko Super Moderator ISPConfig Developer

    You can only have one SSL web site per IP address. It's an Apache/SSL limitation...

Share This Page