SSL troubleshooting: loaded another site

Discussion in 'ISPConfig 3 Priority Support' started by faberchr, Aug 3, 2018.

  1. faberchr

    faberchr Member

    today I created a new website, let say is Logged via shell i used certbot to configure HTTPS. I used this method for dozen of websited and always worked.

    This time, unfortunately, this method failed. When I try to load the website (Opera, Chrome and Firefox). It loads another website (let say I tryed to delete/renew the certificate on both and but nothing happens.

    May I have help about this topic?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    One site note, never use certbot to reconfigure the vhost automatically when creating a cert on the shell, certbot is not able to modify the vhost config correctly for sites as it duplicates some code which needs to be unique.
  4. faberchr

    faberchr Member

    Hello, thanks for your reply. So, selecting both SSL and Let's Encrypr SSL on "domain" page outputs this:

    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Plugins selected: Authenticator webroot, Installer None
    Cert not yet due for renewal
    Keeping the existing certificate
    the /var/www/newsitecom/ssl/ directory is empty.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This does not seem to be ISPConfiug debug output. Please do what I suggested in #2. Enable debug log level, comment out the cronjob, then enable SSL and let's encrypt in the website and then run and post the output.
  6. faberchr

    faberchr Member

    Sorry, maybe it's my fault. But I did exactly what asked in #2.

    Anyway, I solved by myself thanks.

    For each domain, even if they are already served by "certbot", i checked both SSL and Let's encrypt. I noticed that, sometimes, I've to repeat the whole operation two or three times.

    If you wish @till, I can debug more :)

    Thanks for your help.

Share This Page