Statistics admin Bug????

Discussion in 'General' started by AlexanderTheGr, Jan 14, 2006.

  1. AlexanderTheGr

    AlexanderTheGr New Member

    I thing this could be a bug.

    I have create a new site with 200MB disk space

    I loged as user admin to this site and i have uploaded (By using FTP) the site's file (Many pics and sounds available for donwloads) almost 150MB

    I checked how many disk space i used to this site. It said me 150MB. All work fine hire.

    Now i have changed the permitions to dowloaded directories to 717 and to all downloaded files to 644.

    I checked again how many disk space i used to this site. It said me 29MB!!!!. This is not right because i am using 150MB and not 29MB.

    I noticed the problem is cause i have chaged the permision specialy the group perimetions. The group permition should be 5 (read and execute) to get the right report.

    Off course the quota works fine and it does not allow me to extend the storage limit space... but the report of using space is wronk

    I am sure but i think the bandwith report is wronk also.....

    PS: Sory about my bad english

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no bug. If you want to change the permissions of files manually you have to configure the "du" command to be executed with root priveliges by sudo.

    Then add the line:

    $go_info["server"]["sudo_du_enabled"] = true;

    to the file /home/admispconfig/ispconfig/lib/
  3. AlexanderTheGr

    AlexanderTheGr New Member

    And how can I do it this step by step? I am using debian
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Last edited: Jan 15, 2006
  5. AlexanderTheGr

    AlexanderTheGr New Member

    It worked thx a lot :D
  6. Ovidiu

    Ovidiu Active Member

    I already had found that setting for the du sudo :) but I did not think further so I did not insert admispconfig into sudoers :-(

    Now that I read the post you linked to I tried modifying my sudoers like this:
    I added that line using visudo and tried su admispconfig then du -s -c -h web2/ and here is the output:

    BUT I can get this output even without putting admispconfig into sudoers , strange...

    so now that this works, shouldn't ispcfg display the corect values?
    well I tried again, the details about the folders file usage is now there, BUT it still says:

    meaning the folder sizes do not get added up to the total, total still only shows the size of the databases...


    I noticed it does not work for the largest site, the smaller ones display correct values.
    here is the one that does not comply:

    Last edited: Mar 9, 2006
  7. Ovidiu

    Ovidiu Active Member

    anymore ideas? it seems like the total DB space does not add to the total web space and logs are growing over the fixed size I set in ISPCFG panel
  8. Norman

    Norman Member HowtoForge Supporter

    Seems to me that the sudo-check is broken in ispconfig =(

    Even though sudo is enabled in /etc/sudoers for admispconfig it doesnt seem to show all the directories in statistics when I've run chmod 701 /var/www/web*

    I dont want other users snooping in eachothers directories, and I dont want to have to chroot everyone. Too much overhead.
  9. AlexanderTheGr

    AlexanderTheGr New Member

    try this to the sudoers

    admispconfig ALL=NOPASSWD: /usr/[COLOR="Red"]s[/COLOR]bin/du *
  10. Ovidiu

    Ovidiu Active Member

    its /usr/bin/du on Debian
  11. fozy

    fozy New Member

    Perfect for me to work, use Ubuntu 7.10

    Sorry for my English google

    Perfect for me to work, use Ubuntu 7.10

    Changed the file home/admispconfig/ispconfig/lib/

    $go_info["server"]["sudo_du_enabled"] = 1;

    //After edited /etc/sudoers

    $ sudoedit

    // I added the line that our friend AlexanderTheGr said.

    admispconfig ALL = NOPASSWD: /usr/bin/du *

    and the services performed:

    /etc/init.d/ispconfig_server restart
    /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php
    /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php
    /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php

  12. Norman

    Norman Member HowtoForge Supporter

    the exact row Im using in debian is:

    admispconfig ALL=NOPASSWD : /usr/bin/du
    then changed in /home/admispconfig/ispconfig/lib/

    the row

    $go_info["server"]["sudo_du_enabled"] = 0;
    $go_info["server"]["sudo_du_enabled"] = 1;

    Works for me :)

Share This Page