Sugar installation PHP error

Discussion in 'Installation/Configuration' started by pborm, Aug 22, 2006.

  1. pborm

    pborm New Member

    Hello, I'm currently installing a Sugar instance. I get two errors or warnings,

    the session save path dissappear if I turn on Safe mode inside ispconfig, but sugar doesn't want safe mode turned on.

    I'm using Fedora. I also tried manually editing the /etc/php.ini file with no effect. My guess is that I'd have to put something in the "Apache Directives" field in the ISPConfig. Any ideas??
  2. patulo

    patulo New Member

    try this

    Edit "/etc/php4/apache2/php.ini" and set this:

    memory_limit = 32M
    session.save_path = /var/tmp

    and, check if /var/tmp exist and if it has 777 permisions.
  3. pborm

    pborm New Member

    I'm running Fedora. I get to the apache stuff through /etc/httpd..... and my php.ini is in /etc/php.ini

    I've tried setting the stuff in php.ini, but for some reason its not recognizing it there... I have the memory_limit set to 40M there and I already did a chmod 777 on the directory it has the session_save_path as
  4. pborm

    pborm New Member

    oh yeah, I'm also running php 5
  5. patulo

    patulo New Member

    try to look for other php.ini's

    try a find / -name "php.ini", to see if are other config fie that could be used by apache.

    Just to be sure, are you restarting apache when you change the php.ini ?.
    Are you using mod_php or php-cgi ?
  6. pborm

    pborm New Member

    ok, I added this to the "Apache Directives" section in the config for the site in ISPConfig...

    Now, everything greens up, but I get this new error....
  7. falko

    falko Super Moderator ISPConfig Developer

    Try to remove
    php_admin_value open_basedir /var/www/html/web10/
    and make sure PHP Safe Mode is disabled.
  8. pillul

    pillul New Member

    and restart apache !

Share This Page