SuSe 9.3 64-bit apt-get question...

Discussion in 'HOWTO-Related Questions' started by Bailx, Jan 10, 2006.

  1. Bailx

    Bailx New Member

    I'm following the perfect suse 9.3 howto, except i've been modifying things a little bit since i'm running the 64-bit version.

    when installing apt i went with the top two listed here (haven't tried jmorris, but should it matter?)

    for my sources.list, i've been using this

    everything has been going fine, except when I got to mysql & mysql-devel. It's telling me failed: cpio: Bad magic. It seems that this would mean corrupted packages...

    no doubt i could get this installed in some other way, but I was trying to follow the howto as best as I could, so that perhaps other people could benefit...

    any help that someone might lend would be appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    In that case I'd try to install these packages with yast.
  3. gimhan90

    gimhan90 New Member

    Quota configuration error/ suse 9.3


    i too use 64 bit version and followed the how to steps as neccesary changes for 64 bit. but when i tried to install apt-get , i got following error. pls give me a hint .

    please chkeck my steps.

    su93254144:/etc # rpm -ivh
    su93254144:/etc # rpm -ivh

    install apt on suse 9.3/64 bit

    su93254144:/etc/apt # vi sources.list
    # A very basic sources.list file.
    # Remove "base" in case you are behind a slow connection.
    # Fastest repository comes first, with netselect it is possible to determine
    # the fastest repository easily.
    # Visit the server to determine which apt components are provided.
    rpm ftp://mirrors.mathematik.uni-bielefe...inux/suse/apt/ SuSE/9.3-x86_64 update security rpmkeys
    rpm SuSE/9.3-x86_64 update security rpmkeys

    # The list with all available components can be found at:
    # Some components provide experimental software, select wisely!

    # Consult the link above if you want to include uri's for src rp

    su93254144:/etc/apt # apt-get update
    apt-get: error while loading shared libraries: cannot open shared object file: No such file or directory

    Now i also can't use yast - i , instaed of apt-get , because when i use yast - i packagename , system asked some missing system libries. Pls try to resolve the atleast yast .
  4. falko

    falko Super Moderator ISPConfig Developer

    But does
    instead of
    yast -i <package name>
  5. gimhan90

    gimhan90 New Member

    yast -i packagename -----> pop up a screen (about Package Dependencies ) and mentioned about some libriries are missing. (, )
  6. falko

    falko Super Moderator ISPConfig Developer

    No, don't use
    yast -i <package name>
    , simply run
    (no other parameters)!
  7. gimhan90

    gimhan90 New Member


    pop up the "Yast Control Centre " .

    and when i went to the ,

    Software ----> Install and Remove Software .

    Result---> same missing library files screen was displayed .:(
  8. falko

    falko Super Moderator ISPConfig Developer

    I recommend to re-install the system; it seems to be really messed up!
  9. gimhan90

    gimhan90 New Member

    Do U mean re-install the Operating system ? :(
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. If yast is not able to install a package your system must be really mesed up and if you dont have really good linux knowledge the best solution is a reinstall of the OS.

Share This Page