The logs in the Monitor tab doesn't update

Discussion in 'General' started by [email protected], Jan 22, 2017.


    [email protected] New Member

    I have been running ISPConfig for years. Using different versions on different servers. Haven't had this problem before.
    I had one of my disks in my RAID crash, and had it changed. I reconfigured the RAID, and everything seems to be running smoothly.
    Yet, when entering the Monitor tab of ISPConfig (3.1.1p1), the logs are stuck at the time for the change of the disk (2016/12/31).
    The warning regarding the RAID-failure is still there.
    I've found that it might be related to the script, but cannot figure out how to fix it.

    The cron for root looks like this:
    * * * * * /usr/local/ispconfig/server/ 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    * * * * * /usr/local/ispconfig/server/ 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done

    If I try to run the script error manually, I get this error:
    PHP Fatal error: Call to undefined method functions::intval() in /usr/local/ispconfig/server/lib/classes/ on line 122
    The same error gets recorded in ISPConfigs cron log, when DEBUG is turned on.

    I'm still able to add mailusers, mailaliases, add sites, change site directives etc.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The intval function exists in the ispconfig functions class. Download ispconfig 3.1.1p1 again, unpack it and run the update.php script in the install folder. a reconfigure services is not required. Then check if that solved the error.

Share This Page