The Perfect Server CentOS 7.2 with Apache...

Discussion in 'Developers' Forum' started by spido, Oct 28, 2016.

  1. spido

    spido Member

    Hi guys!

    I'm not sure that I write in the appropriate section of the forum ...

    I downloaded the file of the virtual machine: The Perfect Server CentOS 7.2 with Apache, Postfix, Dovecot, Pure-FTPD, BIND and ISPConfig 3.1.
    Install a virtual machine on ESXi 6.0.
    Everything went well, the VM booted.
    I see the network settings: IP, mask
    This corresponds to my network.
    I entered in the browser, Nothing happens, the page will not load.
    I entered:
    Nothing happens.

    But I do a ping in PowerShell to 192.168.100, Ping is going well.

    Why not start webserver and ISPconfig?
    What am I doing wrong?

    Thank you in advance!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig and web server are sorted. Most likely the CentOS firewall kicked in, please run:

    iptables --flush

    and try again.
  3. spido

    spido Member

    I have implemented the command.
    But it does not help.
    See screenshot.

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Can you ping google from within the vm:

    ping -c 1

    and run this command:

    netstat -ntap

    to see if apache and ispconfig are running.
  5. spido

    spido Member

    ping -c 1 went well.

    I do not see that run Apache and the ISPConfig, on tcp.

    See screenshot.

    Attached Files:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    systemctl enable httpd
    systemctl start httpd

    and try to connect again.
  7. spido

    spido Member

    I ran the two teams, but httpd does not start.
    I launched
    netstat -ntap
    but the table does not include httpd for tcp.
  8. till

    till Super Moderator Staff Member ISPConfig Developer


    service httpd restart

    and if it does not come up and shows no eror on the shell, then please take a look into the apache error log in /var/log/httpd/
  9. spido

    spido Member

    restart does not help
    further I get /var/log/httpd/error_log permission denied
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, strange. But the error.log exists and you are logged in as root user?
  11. spido

    spido Member

    Yes, I logged in as the Root user.
    The screenshots above, it shows.

    And who compiled this virtual machine?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I compiled this virtual machine and I use it here since then for ISPConfig development, it works here without issues on VMWare workstation. I will redownload the image and make a fresh vm to see if I can reproduce your issues.
  13. spido

    spido Member

    I understood.
    I look forward to your report.

    And further:
    I downloaded to test virtual machine The Perfect Server - Ubuntu 16.10 (Yakkety Yak) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1 as ready to use virtual machine image download in ova / ovf format, compatible with VMWare and VirtualBox.
    Installed on ESXi 6.0.

    Address Page displays Apache2 Ubuntu Default Page.

    What is the address of a CP ISPconfig?

    I will not let the virtual machine as the Root user.
    He writes that the password is incorrect. (howtoforge)

    But I need a virtual machine Centos 7.2 - from a professional system administrator.
    I have to study all the settings correct installation. But just right.
    You will be able to fix or rebuild again VM?
    If the virtual machine is created Centos 7.2 for Hyper-v 2016, it will be absolutely wonderful.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I downloaded and installed the CentOS 7.2 image here and it works fine here, I just had to run the "iptables --flush". Seems as if there is a bug in firewalld, it adds rules to iptables even when it is disabled as fail2ban seems to load it partially. I will upload a new image where I updated the centos packages and ispconfig plus I added some commands to open the ports that get closed to the firewalld bug after each reboot.

    As usual, port 8080 on any IP or domain that points to the server.

    Ubuntu systems never let you login as root user, root is disabled. You have to use the username "administrator" and password "howtoforge", then run "sudo -s" and enter the password again. That's described at the end of the tutorial.

    Btw, Ubuntu 16.04 (LTS) is a better option than CentOS if you need a long time stable setup.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The new image will be uploaded in about 2 hours.
  16. spido

    spido Member

    Thank you to quickly react to the problem.

    I need a web server with Centos.
    I administer windows.
    Hyper-V only supports RedHat/Centos.
    I can not choose.
    Now I will study Centos.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

  18. spido

    spido Member

    Yes, now almost equally supported by windows.
    I am 8 years ago, studied ubuntu, but sleep did not like. Too unstable and a lot of mistakes.
    Now Perhaps something has changed.

    But I noticed that the virtual machine with Centos, load 2-3 times faster than Ubuntu.
  19. spido

    spido Member

    Now it works.
    This virtual machine can be used in production?

    Many thanks!
    Last edited: Oct 29, 2016
  20. spido

    spido Member

    Convert ESXi virtual machine in Hyper-V 1 generation, I used 5nine converter.
    I did try and with the converter StarWind V2V, but also failed.
    Conversion fails, the virtual machine is loaded with errors and does not work.
    This is a tragedy ...

    Perhaps you plan to create a virtual machine to Hyper-V 2016 2 generation?
    I think it will be interesting not only to me.

Share This Page