The Perfect Setup - Fedora Core 4

Discussion in 'HOWTO-Related Questions' started by amdserver, Oct 10, 2005.

Thread Status:
Not open for further replies.
  1. meetec

    meetec New Member

    HTML::parser -- NOT OK

    When I run 'install DB_File','install Net:DNS','install Digest:SHA1'
    On the end a get

    make: *** No rule to make target 'HTML::parser'. Stop
    /usr/bin/make install HTML::parser -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, in stall seems impossible


    What's wrong with this picture :)))
  2. falko

    falko Super Moderator Howtoforge Staff

    You could try to find Fedora packages instead of installing these Perl modules manually. E.g., run
    yum search DB_File
    to find an appropriate package, and if there is one, run
    yum install <package name>
    to install it.
  3. yvovandoorn

    yvovandoorn New Member

    Hey there

    Using your guide to ultimately setup ISPConfig. However I am currently stuck, only because of the following reason.

    I am installing FC4 on an old Powermac G4 400Mhz with 512megs of ram. FC4 PPC has the same amount of packages as the i386 and this is not where the problem lies. It is the part where we have to use a package from Fedora Core 1, the IMAP package. Unfortunately simply replacing the i386 for ppc isn't going to cover it here as FC1 for PPC was never released thus there is no imap package for it.

    I have tried somethings before I posted here though.

    1. I tried using Yellowdog Linux (PPC based linux based off of Fedora prior to FC4) and it used an IMAP client all the way up until 3.0.1. Added it to my sources.list file but I get a dependency problem:

    [root@disgruntled-dutch ~]# apt-get install imap
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
      imap: Depends:
    E: Broken packages
    So that definitely didn't work. I tried getting the SRPM from a website I found online and it got the package and it seemed like it installed it but it seemed nothing happened:

    [root@disgruntled-dutch ~]# rpm -ivh
       1:imap                   ########################################### [100%]
    Thinking it was installed I tried this part of the guide again:
    [root@disgruntled-dutch ~]# chkconfig imap on
    error reading information on service imap: No such file or directory
    [root@disgruntled-dutch ~]# chkconfig imaps on
    error reading information on service imaps: No such file or directory
    [root@disgruntled-dutch ~]# chkconfig ipop3 on
    error reading information on service ipop3: No such file or directory
    [root@disgruntled-dutch ~]# chkconfig pop3s on
    error reading information on service pop3s: No such file or directory
    [root@disgruntled-dutch ~]# 
    Last thing I tried, but miserably failed to do was go to UW IMAP's website and manually compile the utility. The documentation by the UWers are very poor (unfortunately).

    I tried 'make slx' and unfortunately got a lot of make errors.

    So I am calling out the help of any person who knows either
    1. A PPC package that will replace IMAP
    2. How to get IMAP to work for Fedora Core 4 (PPC)

  4. yvovandoorn

    yvovandoorn New Member

    Using Dovecot right now... going to install ISPConfig and see if it likes it.
  5. falko

    falko Super Moderator Howtoforge Staff

    You installed a source rpm, not a binary rpm... You can compile a binary rpm from a source rpm, but I don't have instructions at hand. Maybe Google has...
  6. yvovandoorn

    yvovandoorn New Member

    mysql 5.0.15 (stable) came out today... any idea on how to install that?
  7. Romeo

    Romeo New Member

    Ive managed to get it all running smoothly but I have one small problem

    When i enter for ISPConfig, i get the following error message from firefox:

    "Could not establish a encrypted connection because certificate presented by is invalid or corrupt"

    It happens even if i use https://localhost:81

    I am guessing something went wrong whilst I was creating the SSL certificates, how can I resolve this?
  8. falko

    falko Super Moderator Howtoforge Staff

    Do you have the same problem in another browser, e.g. IE?
  9. Romeo

    Romeo New Member

    Similar error message in IE :confused:
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    It seems that your SSL certificates is broken.

    1) Make a new SSL Certificate:

    2) Copy the certificate to:


    and the key to:


    3) Restart the ISPCOnfig webserver:

    /etc/init.d/ispconfig_server restart
  11. Romeo

    Romeo New Member

    Worked perfectly, cheers bud

    Just a few final questions:

    Is PHPMyAdmin pre-installed or will i have to install it?
    Where is the GUI for the FTP server? (need to change ports and add users etc)
    Is there a GUI for postfix?
    Also certain links within ISPConfig refuse to System Config > Settings and Server > Settings in the Management section
    Last edited: Oct 27, 2005
  12. falko

    falko Super Moderator Howtoforge Staff

    You have to install it, use the Update Manager under Management for it. You can find phpMyAdmin packages here:

    The interface for Web-FTP is under Web-FTP. :D
    You create the users under "User & Email" in a web site under ISP-Manager.

    When you try to access ISPConfig, you have to use the same URL than you specified during installation. You can change this in /home/admispconfig/ispconfig/lib/
  13. Romeo

    Romeo New Member

    Cheers for that :) Installing now


    So do I add/delete users from ISPConfig?

    For some reason ISPConfig added www before the url, fixed now and all working :)

    I changed the FTP Server port to 50001 yet in the services, it still shows FTP as offline even though I've restarted ProFTPD
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, all email settings are done inside ISPConfig.

    ISPConfig looks for a FTP server listening on localhost on the default ftp port. If your ftpd listens on another port or IP it will be shown offline in the controlpanel.
  15. falko

    falko Super Moderator Howtoforge Staff

    Also under "User & Email".

    Yes, ISPConfig checks port 21 for FTP.
  16. Romeo

    Romeo New Member


    So how can i change ISPConfig to pick up the FTP server on 50001?

    Also i clicked on Web-FTP then added a new username and password for the site but i get "Could Not Connect to LocalHost" yet I am using the domain provided during ISPConfig and when setting up the client site?
  17. egomouse

    egomouse New Member

    One problem - my system won't boot now. I get the following error on boot up

    fschk.ext3: Unable to resolve 'LABEL=/'

    enter password for maintenance for CTRL D to reboot. So i thought i would delete that line to start with and make sure the system could boot but i can't edit the file now. !!!!!! HELP!!!!
  18. falko

    falko Super Moderator Howtoforge Staff

    You can use a rescue CD like "Timo's Rescue CD" to repair your system.
    I can only guess what has happened. Did you maybe mess up /etc/fstab when trying to enable quota? Or is it a hard disk failure?
  19. falko

    falko Super Moderator Howtoforge Staff

    ISPConfig assumes that your FTP server is listening on port 21, that's why you have these problems. To change that, I'd have a look at the files in /home/admispconfig/ispconfig/lib/classes and /home/admispconfig/ispconfig/lib/plugins.
  20. Romeo

    Romeo New Member

    Just wont work no matter what I do so left it as a local FTP server only

    Cheers for all the help though

    FInal question regarding security. How can I lock down this box? Need to make it as secure as possible
Thread Status:
Not open for further replies.

Share This Page