Trouble with Mail Server

Discussion in 'General' started by Jcorrea920, Feb 17, 2006.

  1. Jcorrea920

    Jcorrea920 New Member

    I am running Fedora Core 4 Perfect setup since last year.
    By default ISPConfig uses Mbox instead of Maildir/ to hold emails. I changed it to Maildir/ so that our email clients could use it better without taking up too much space on server.
    Some time on Friday Feb 11 the mail stopped working nobody could receive email from outside our local network(outside world) but smtpd still worked fine sending mail out. So since I haven't updated the software in months I ran an apt-get-install updates, but still no pop mail service. Then I ran
    up2date -u and boy did it download and install a lot of updates, but still no dice.
    So I discovered that it must be ipop3d that is not working properly since the error message in /var/logs/mail are Error 554 relay-access denied ipop3d[15485] Mailbox Vulnerable /var/spool/mail must have 1777 protection.

    Before debugging I backed up the ISPConfig Database and All WebSites on the Server.

    Then I discovered that all the Maildir/ directories were somehow converted to Mbox files. I tinkered around with Postfix, but according to the file I am set up to have Maildir/ but actually don't. Could it be my CyrusIMAP that has gone rogue? If anyone can help me get my mail server back on line and back to the Maildir/ directories, I would greatly appreciate it.;)
  2. falko

    falko Super Moderator Howtoforge Staff

  3. Jcorrea920

    Jcorrea920 New Member

    I ran chkrootkit and rkhunter

    I don't have and infection after running the scans but there were some interesting results. When scanning hidden files:
    And then a security advisory says that root login through SSH is possible:

    What I need is to a conversion from mbox to Maildir/ and I need to start up my CyrusIMAP and forget about ipop3d. With ISPConfig all of the email accounts do not have shell accounts so running a generic conversion tool under the specified user's shell account would be pointless. How could I fix the problem? How could I do that with ISPConfig?:confused:
  4. falko

    falko Super Moderator Howtoforge Staff

    I don't think it's something serious, but have a look at /dev/.udevdb anyway:
    ls -la /dev/.udevdb

    This means only that root logins are allowed - this doesn't mean that your server got hackec or that anyone can get in without knowing the root password. A more secure configuration would be to disallow root logins, then you'd have to log in as another user first and then use su to become root.

    If you want to use Maildir, then you must enable Maildir in ISPConfig: Management -> Server -> Settings -> Maildir.
    To convert from mbox to Maildir, have a look at mb2md:
  5. Jcorrea920

    Jcorrea920 New Member

    Error 554 with Mail Server "Relay Access Denied"

    I checked the dev/.udevdb directory and this is what I found:


    Should I be concerned?

    I get this error when trying to send mail from Microsoft Outlook. On my email account on Thunderbird I can send mail but mail received gets bounced with the same error 554 "Relay Access Denied"


    How do I fix this?
    Last edited: Apr 7, 2006
  6. falko

    falko Super Moderator Howtoforge Staff

    I don't think so.

    You must enable "Server requires authentication." in Outlook, like here:

Share This Page