turn off "PHP Scripts" problem after updated php

Discussion in 'Installation/Configuration' started by k-dev4edv, Feb 6, 2006.

  1. k-dev4edv

    k-dev4edv New Member

    Hi, after I had updated the php version on my debian 3.1 server (from 5.0.5 to 5.1.2), apache ignores my settings for php in the "ISP Manager"-Tool.
    When I turn off "PHP Scripts", the scripts are still executed, only the "PHP Safe Mode"-setting works correctly. I tried to reinstall ISPConfig with "./setup", but the problem still occurs. :( PHP is now globally activated for all websites on my server. Is there a way to get back the control over my apache php settings by ISPConfig, e.g. delete apache config before reinstall ISPConfig, ...? :confused:
  2. falko

    falko Super Moderator Howtoforge Staff

    If PHP is globally enabled, it will work, no matter what you specify in ISPConfig.
    You must disable PHP in your Apache configuration, as outlined in the "Perfect Setup" guides on HowtoForge.
  3. k-dev4edv

    k-dev4edv New Member

    That's it

    Thank you very much. :D
    I forgot to look into the file /etc/apache2/mods-enabled/php5.1.conf
    Shame on me. :p

Share This Page