Ubuntu 14.04 desktop vnc4server startup script issue

Discussion in 'HOWTO-Related Questions' started by ryawych20, Sep 2, 2014.

  1. ryawych20

    ryawych20 New Member

    Hello to everyone! I have made everething like it is in: How To Install VNC Server On Ubuntu 14.04
    But after reboot vncserver was not started
    And i tried to start it by hands, i typed:
    # service vncserver start
    and got these errors:
    # /etc/vncserver$ service vncserver start
    /etc/init.d/vncserver: 2: /etc/vncserver/vncservers.conf: VNCSERVERARGS[1]=-geometry 1600x1200: not found
    $Starting $VNC server: /etc/init.d/vncserver: 25: test: unexpected operator
    also before this forum i tried to google these errors, but didn't find anything
  2. srijan

    srijan New Member HowtoForge Supporter

    Once you have added the vncserver, you need to run
    after reboot if the service don't starts after boot
  3. ryawych20

    ryawych20 New Member

    srijan, thanks for your quick answer. but I don't understand you clearly, the point is to start vnc automaticaly on each box boot, before login, or i missed something?

    And when i creating /etc/init.d/vncserver script like this it means that i create a new service and can access it through service command - is it right?
    So i tried to start it manually to understand what is wrong and got errors.
    Ofc for example i can start it like this each time i boot and login in my box:
    vncserver -geometry 1600x1200 -depth 24
  4. srijan

    srijan New Member HowtoForge Supporter

    VNC server will only start if you are logged in, otherwise it will not start. I mean to say you need to fisrt login at ubuntu server configured with vncserver.

    Yes you can access it only after one reboot.

    If you will add the service in update.rc then it will start automatically by using
    It s not needed as if you added the file /etc/vncserver/vncservers.conf with the entries as

    It is defined in the guide as well.
  5. ryawych20

    ryawych20 New Member

    Yes i added it in update.rc and after restart it didn't start
    i made everething like in the topic
    I'am interesting in these errors that i got
  6. srijan

    srijan New Member HowtoForge Supporter

    It means that your hardware is not supporting the resolution 1024x768, to overcome this change the file /etc/vncserver/vncservers.conf with some other resolution like 800x600


Share This Page