Ubuntu Server

Discussion in 'HOWTO-Related Questions' started by hipnerd, Jan 23, 2006.

  1. hipnerd

    hipnerd New Member

    I have been following the HOWTO guide listed here to create my own domain server for my Windows XP Pro network.

    So far I've had some limited success, but I'm not quite there.

    My largest problem is that I cannot get CUPS to work correctly. Jobs just go to the printer and die a quiet death in queue.

    This is the output of my CUPS error_log file:

    I did have difficulty figuring out where the line:

    "AuthGroupName shadow"​

    belonged in the /etc/cups/cupsd.conf file. I settled for a place in the <Location /admin> section, because that did give me access to the admin area of CUPS, although I suspect this is the wrong place. I cannot find a commented out AuthGroupName line to put this near. It is mentioned once in the "Security Options" directions, but placing it in that area results in an error message.

    Anyone have any help for me on this. I feel like I'm close, but that mythical cigar eludes me.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I've attached a correct cupsd.conf file.

    "AuthGroupName shadow" has to be in the security options section.

    Attached Files:

  3. hipnerd

    hipnerd New Member

    That is where I had the line initially. This is what I get when I put AuthGroupName there:
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you put only AuthGroupName there or used my config file? Its working perfectly without errors in my setup, and thats the setup i ued to writ this howto :)
  5. hipnerd

    hipnerd New Member

    I matched line for line. But just in case I missed something. I copied your cupsd.conf file and edited the IP addresses to match my system.

    Then I restarted CUPS with /etc/init.d/cupsys restart

    Here is the new output of /var/log/cups/error_log:

    It still doesn't like AuthGroupName shadow for some reason.
  6. falko

    falko Super Moderator Howtoforge Staff

    Are you sure you followed the tutorial to the letter?
  7. hipnerd

    hipnerd New Member

    Well, I was drinking heavily at the time, but I'm pretty sure I followed along.

    Obviously, something did not work quite right. So I won't let myself off the hook completely, but I followed the instructions as closely as possible. The only areas where I am aware that I deviated from the instructions was in creating the initial user account. I did not name it "Administrator" because I did not notice that was required. I also installed the SMP kernel as I have a server with dual PIIIs.

    The first place I noticed some deviation from expected responses was in the area involving "quota." I believe that I got some error responses at that point. I attemtped to redo that section in case I made a mistake and got similar results. I decided to plow ahead anyway, on the basis that perhaps those actually were the expected responses. What the heck do I know?

    Then when I attempted to test the setup with:

    smbclient -L localhost -U%

    I noticed that the "print$" line was missing. But the instructions said the output should look similar to the one shown. I figured I would at least complete the installation before peppering the board with questions.

    And in the CUPS web interface, I get this line at the top of all pages:

    Administrative tasks have been disabled for security reasons. Please use Menu System > Administration > Printing.

    Since I am airing all my dirty laundry here. The other problem I have noticed is that when I close my Windows workstations down, they get an error message regarding "roaming profiles." It doesn't appear to be affecting anything. So it was going to be my next plea for help after I solved the CUPS issue, which is preventing me from printing. But who knows? maybe it's related. So I'll throw it in for completeness' sake.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This error occurs when you dont execute this command:

    adduser cupsys shadow
    And then restart Samba:
    /etc/init.d/cupsys restart
  9. hipnerd

    hipnerd New Member

    Actually, I believe in my case, this error occurs because of this problem:

    E [24/Jan/2006:22:49:13 -0800] Unknown directive AuthGroupName on line 748.
    For fun, I attempted to add cupsys to the shadow group. Here is the result:

    root@server1:/home/john# adduser cupsys shadow
    The user `cupsys' is already a member of `shadow'.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Reinstalled the howto today and it installs without problems with the posted cupsd.conf.

    Did you use 32bit or 64bit ubuntu?
  11. hipnerd

    hipnerd New Member

    32-bit server edition (Upgraded kernel to SMP as noted earlier.)
    Last edited: Jan 25, 2006
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I've also installed 32bit system. Its a bit whired that your system complains about a valid configuration directive :confused:
  13. hipnerd

    hipnerd New Member

    I used the server distro. Could that have affected anything? I'm grasping at straws here.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont know. maybe they have changed there anything. I have not tried it with the server distro yet.
  15. hipnerd

    hipnerd New Member

    OH well. Looks like a repartion and restart is in my future. I was hoping to troubleshoot this, but I'll just give it another try from scratch.

    I appreciate your efforts.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    I just saw that i got the same error on the latest install in the error log, but everything is working. Mybe the cups binary was updated since i wrote the howto.

    Did you allow the correct IP addresses in the Auth section for the admin panel and change the listen directive to the IP of your server to get access to the admin part of the web frontend?
    Last edited: Jan 25, 2006
  17. hipnerd

    hipnerd New Member

    <Location /admin>
    # You definitely will want to limit access to the administration functions.
    # The default configuration requires a local connection from a user who
    # is a member of the system group to do any admin tasks.  You can change
    # the group name using the SystemGroup directive.
    AuthType Basic
    AuthClass Group
    ## Restrict access to local domain
    Order Deny,Allow
    Deny From All
    Allow From
    Allow From
    # Encryption Required
    30 is my workstation.

    25 is my server.

    It looks good to me. I think I have angered the Linux gods in some fashion.
  18. hipnerd

    hipnerd New Member

    Just got done with a full wipe. I downloaded a standard Ubuntu iso instead of the "server" iso I had before. Followed the directions exactly and I got:

    I [26/Jan/2006:23:09:53 -0800] Scheduler shutting down normally.
    I [26/Jan/2006:23:09:53 -0800] Listening to 7f000001:631
    I [26/Jan/2006:23:09:53 -0800] Listening to c0a80019:631
    [B]E [26/Jan/2006:23:09:53 -0800] Unknown directive AuthGroupName on line 748.[/B]
    I [26/Jan/2006:23:09:53 -0800] Loaded configuration file "/etc/cups/cupsd.conf"
    I [26/Jan/2006:23:09:53 -0800] Configured for up to 100 clients.
    I [26/Jan/2006:23:09:53 -0800] Allowing up to 100 client connections per host.
    I [26/Jan/2006:23:09:53 -0800] Full reload is required.
    E [26/Jan/2006:23:09:53 -0800] LoadAllPrinters: Unable to open /etc/cups/printers.conf - No such file or direct
    E [26/Jan/2006:23:09:53 -0800] LoadAllClasses: Unable to open /etc/cups/classes.conf - No such file or director
    I [26/Jan/2006:23:09:53 -0800] LoadPPDs: Read "/etc/cups/ppds.dat", 247 PPDs...
    I [26/Jan/2006:23:09:53 -0800] LoadPPDs: No new or changed PPDs...
    I [26/Jan/2006:23:09:53 -0800] Full reload complete.
    Again, when I log into CUPS via the web, I get:

    Administrative tasks have been disabled for security reasons. Please use Menu System > Administration > Printing. at the top of the screen and the "/images/navbar.gif" is missing. (If it is like last time, I can still probably do most tasks, though.)

    I now think that Ubuntu hates me, perhaps because of something I did in a past life and I will have to wait for the karma wheel to turn a full cycle before I can get this to work properly.
  19. hetodd

    hetodd New Member

    Move AuthGroupName to the Admin Location

    I saw the following entry in Google just a couple down from this thread when I googled the same error.

    CUPS Software Administrators Manual
    The AuthGroupName directive sets the group to use for Group authentication.
    The AuthGroupName directive must appear inside a Location directive. ...
    www.cups.org/sam.html - 251k - Cached - Similar pages

    This is a quote from the AuthGroupName section of the CUPS manual:
    "The AuthGroupName directive must appear inside a Location directive."

    I moved it to the admin section the error has disappeared.

    Now I get:
    "Unable to open /etc/cups/classes.conf - No such file or directory"

  20. hetodd

    hetodd New Member

    OK so I did:
    sudo touch /etc/cups/classes.conf

    This created the empty file. I did an ls -l to ensure it had the same permissions as cups.conf.

    I still had a problem in my /var/log/cups/error_log:

    StartListening: Unable to bind socket for address c0a80164:631 - Cannot assign requested address.

    I saw a post indicating that the first part of the address was a translated quad address. I did a ifconfig and saw that my eth0 address was wait -- it's supposed to be! I checked my /etc/network/interfaces

    cat /etc/network interfaces

    ... and it had as the static address. So I figure I must have neglected to restart my network after I modified the interfaces file.

    I restarted my network:

    sudo /etc/init.d/networking restart

    ... and I am running CUPS!

Share This Page