Unable to add a CNAME to DNS

Discussion in 'Installation/Configuration' started by tmdg, Aug 26, 2009.

  1. tmdg

    tmdg New Member


    I'm having a problem adding a CNAME using the DNS manager.

    If I attempt to add a CNAME using DNS Manager I get a message:-
    There is already an A Record entry for this host in this zone
    I have checked that the recycle bins are empty. Both in DNS manager and ISP Manager.
    I've also check the zone file and there is no A record or CNAME for the host I'm trying to add the CNAME for.

    Some history.

    The site www.mydomain.com had been created with a co-domain mydomain.com.
    That all worked fine

    However, the client moved the site to an new host. But wished to stay with the ISPconfig system for Mail.

    When the client moved to the other host I believe the reseller simply went in to DNS Manger and changed the IP address for www but made no changes to the configuration of the ISP manager side of things.

    Now the client wishes to change the www from an A record to a CNAME.

    I looked at what was there and changed the ISP Manager entry from www to web and saved it. That looked to me to have work correctly. That is the symlink from /PATHTO-WEB/www.maydomain.com to /PATHTO-WEB/webNN had been replaced by

    Next I went to DNS manager and deleted the www A record. I emptied the recycle bin. When I attempted to add the CNAME I got the error. Back at the ISP manager I looked in the Co Domains and found an entry there for www so I deleted that too and emptied the recycle bin. However, I am still unable to add the CNAME.

    I check in the zone file and there is no entry for www. So I'm puzzled as to why I can't add the www CNAME.

    I looked in the database table "dns_a" but of course there are many www hosts so it's not easy for me to know if there is an entry for www.mydomain.com.

    Can anyone advise me on the best way to investigate this further.

  2. bad_crow

    bad_crow New Member


    Have you restarted the DNS server (bind I suppose) to load the new config file ? Have you updated the ID in the configuration file ?

    Keep in mind that a CNAME doesn't provide an IP, so you'll need a A record somewhere.
    so if you have WWW pointing on web, you'll need web pointing on a IP.

    Another way to do so is to simply make an redirection to IP from apache so there will be no need to update the DNS. This won't be a final solution but this will do till you find your problem and resolve it.
  3. tmdg

    tmdg New Member

    Thanks Bad Crow but that is not the problem. If I add a CNAME such as apache.mydomain.com the ISPconfig takes no problem. The problem is in ISPconfig some place.

    I fixed my actual problem by hand cranking the cname in to the zone file below the


    But it really need to be controlled by ISPconfig.

  4. tmdg

    tmdg New Member

    Problem almost solved. :)

    I have identified the bad record in the dns_a table. I was able to identify the record causing the problem by using the ip address. I changed the host field to wwwbad.

    Now when I try to add a CNAME for wwwbad I get the error but when I add a CNAME for www it works just fine.

    So now the question is can I just delete the bad entry from the table?

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Better leave the record in the database.

Share This Page