Unable to send/receive email from Outlook Express

Discussion in 'Installation/Configuration' started by asokaajay, Nov 25, 2005.

  1. falko

    falko Super Moderator Howtoforge Staff

    Which distribution do you use?
    The installation of Courier is mentioned in most of the "Perfect Setup" tutorials on HowtoForge.
  2. piyopiyo

    piyopiyo New Member

    I am using the FC4 and followed the The Perfect Setup - Fedora Core 4. I checked the Perfect Setup SuSe and that has a section describing Courier-IMAP/Courier-POP3 setup and this section is not there in the Perfect Setup FC4. Please let me know what changes that I need to make,if tehre is any, on the exisiting system prior to the installation of Courier-IMAP and Courier-POP3.

  3. falko

    falko Super Moderator Howtoforge Staff

    Unfortunately, on Fedora, there are no Courier packages available, that's why that section is missing in the Fedora tutorials...:(
  4. piyopiyo

    piyopiyo New Member

    Thanks for the information. I have tried several things to debug the problem in sending mail with outlook and has no success. one thing that i noticed in the maillog is the following error message

    Jan 9 02:45:42 ns1 postfix/qmgr[10354]: CA8239B010E: from=<[email protected]>, size=754, nrcpt=1 (queue active)
    Jan 9 02:45:42 ns1 postfix/smtp[13796]: CA8239B010E: host mx1.optonline.net[] said: 450 4.2.1 Your host has no DNS record . If you are using a firewall please configure DNS and try again authoritative host not found (in reply to MAIL FROM command)

    Found some way to troubleshoot postfix from http://www.postfix-book.com/debugging.html and tried

    telnet relay-test.mail-abuse.org

    but this gives relay access denied error message. Does any of this relate to the issue that I have with outlook?

    [root@ns1 web1]# telnet relay-test.mail-abuse.org
    Connected to relay-test.mail-abuse.org (
    Escape character is '^]'.
    Connecting to ...
    <<< 220 *********************************
    >>> HELO cygnus.mail-abuse.org
    <<< 250 ns1.incnetworks.com
    :Relay test: #Quote test
    >>> mail from: <spamtest@>
    <<< 501 Bad address syntax
    >>> rset
    <<< 250 Ok
    :Relay test: #Test 1
    >>> mail from: <[email protected]>
    <<< 250 Ok
    >>> rcpt to: <[email protected]>
    <<< 554 <[email protected]>: Relay access denied
  5. falko

    falko Super Moderator Howtoforge Staff

    Is your Fedora server's IP address?
  6. piyopiyo

    piyopiyo New Member


    I get a different error when ussing Thunderbird client.
    Jan 9 13:52:22 ns1 postfix/smtpd[20167]: connect from unknown[]
    Jan 9 13:52:30 ns1 ipop3d[21426]: pop3 service init from
    Jan 9 13:52:30 ns1 ipop3d[21426]: Command stream end of file while reading line user=??? host=[]

    Thanks for all your efforts to help me.

  7. piyopiyo

    piyopiyo New Member

    I tried telnet to the server from a remote machine on port 25 and it cannot connect.

    telnet incnetworks.com 25
    gives me :
    220 *************************************

    Also, the maillog displays:
    Jan 9 14:17:38 ns1 postfix/smtpd[13743]: connect from unknown[]

    I captured the incoming packets on the server:

    1 23.683053 -> TCP 62932 > smtp [SYN] Seq=0 Ack=0 Win=65535 Len=0 MSS=1460
    22 23.683098 -> TCP smtp > 62932 [SYN, ACK] Seq=0 Ack=1 Win=5840 Len=0 MSS=1460
    23 23.697292 -> TCP 62932 > smtp [ACK] Seq=1 Ack=1 Win=65535 Len=0
    24 23.697752 -> DNS Standard query PTR
    25 23.706535 -> DNS Standard query response, No such name
    26 23.707044 -> SMTP Response: 220 ns1.incnetworks.com ESMTP Postfix27 23.854551 -> TCP 62932 > smtp [ACK] Seq=1 Ack=40 Win=65496 Len=0 - is the network from which I am trying to connect - is the private IP of the FC4 server - is the DNS server of our ISP

  8. piyopiyo

    piyopiyo New Member

    I wasn't very clear in my earlier posts. I am running the ISPConfig on a private IP address. The public IP address from our ISP is directly mapped to the private IP. Right noe there is no firewall on the public IP so all the traffic will be forwarded to the ISPConfig server.
    Public IP -
    Private IP -

    I think my issue can be solved by doing split DNS. I would appreciate any comments.

  9. falko

    falko Super Moderator Howtoforge Staff

    The problem might be that does not have a reverse DNS (PTR) record.
    However, this isn't related to your Outlook/Thunderbird problem...
  10. piyopiyo

    piyopiyo New Member

    Thanks, Falko. I am palnning to setup the server on a Public IP and this may solve the problem. As I understand from one of your posts on another thread, ISPConfig is meant to work with machines connected directly on the internet. I tried doing the split DNS and was stuck with few things.

  11. falko

    falko Super Moderator Howtoforge Staff

    Yes, that's right.
  12. piyopiyo

    piyopiyo New Member

    thanks falko. i have everything working now after installing ISPconfig on a public IP address. thanks again for all the hardwork.


Share This Page