Unable to upload files/directories with new FTP user

Discussion in 'General' started by Micron65, Jul 16, 2021.

  1. Micron65

    Micron65 New Member

    I have a clean install of ISPConfig on Debian 10. Nothing has been changed except the password for the admin account.

    I've added a site and DNS is working properly.

    I then added an FTP user to the website, however upon attempting to upload files/directories via FileZilla, I run into errors like these;

    Command: MKD assets
    Response: 550 Can't create directory: Operation not permitted
    What needs to be done additionally to provide FTP users with write access with ISPConfig? I was expecting it to work 'out of the box' but obviously this isn't the case.

    Have created an account at Gitlab to report the issue but my account is awaiting approval of some kind.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Where did you try to create that directory or upload files or directories? Directories can only be created and files and directories uploaded within the 'web' directory and within the 'private' directory of your website. I guess you tried to create a directory in / of the FTP login, which is not allowed. Go to the 'web' directory, which is the / directory when you access the site by HTTP, or go to the 'private directory, which is used for any files that shall not be accessible by http.
  3. Micron65

    Micron65 New Member

    It worked on the second try, no changes were made.
    I've abandoned ISPConfig altogether now at any rate since I was also unable to receive inbound emails on a Debian 10 server. Will look for another solution that works 'out of the box' or will just install everything I need manually.
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Maybe there is a firewall issue, or something like that. Feel free to open a thread for your issue. ISPConfig is great software ;)

Share This Page