Upgrade Nightmare!

Discussion in 'Desktop Operation' started by jmf346, Dec 11, 2010.

  1. jmf346

    jmf346 New Member

    Thanks in advance for any help! I’m running Ubuntu 10.10 x64 server with gnome desktop. The purpose of this machine is many. But mainly it's my home server for family photos, files, etc. It's (was) also my MythTV Backend / Frontend for my living room entertainment center. Last week I upgraded MythTV to 0.23 from 0.24. I had numerous dependency problems. In fact about a month prior I upgraded Ubuntu from 10.04 to 10.10, and I'm honestly not sure if all of my packages successfully upgraded. Then, like a fool - I decided I'd mess around with upgrading MythTV.

    Well now, I can't even get the computer to boot properly and my wife is about ready to have my head! She wants to watch Christmas specials and Christmas movies that we have saved on the computer, but now nothing is available.

    I'm a relative beginner to the Linux community, having just delved into this world about 14 months ago. My main problem is that I have no idea what went wrong and I don't even know where to begin to trouble shoot. I know that the problem began when I did "sudo apt-get upgrade" and answered yes to upgrade over 1,000 packages. I was having some trouble with some dependency issues on some of the video packages and was having some difficulty with having reliable video and audio with MythTV. Following a suggestion on a message board about moving past unmet dependencies I did "sudo apt-get upgrade -f" to force the upgrade. That seemed to get things moving forward, but I was soon met with grave disappointment... One of the 1,000 packages that we getting upgraded apparently did something with "dpkg-reconfig" or something. Admittedly, I wasn’t paying much attention unfortunealy. :( I got a blue/gray screen with a bunch of questions. I picked all of the recommended settings. I did notice that one of the questions something to do with the package "mdadm". (NOTE - I am running a software RAID 5 configured with mdadm and also running LVM. When I check the status of my arrays, I find that all are up and running. All hard disks look good too). After a few of the packages were done upgrading it required me to restart.

    Upon restart I have not been able to get back into the desktop environment. Machine boots, I get the "Ubuntu 10.10" screen with the little red / white dots indicating a progress bar. Then it says, disks need to be check, then it says "An Error Occurred while mounting /virtual. Press S to skip mounting or M for manual recovery." If I hit S, it then says the same thing for /tmp, /home, /var/lib/mysql, /var/log, /var/mail, /var/www.

    I read something that suggested this may be a timing issue. That by the time these partitions are being called for, they're not yet ready and mounted. Not sure how to follow-up on that.
    My fstab has not been changed, and looks find to me. I am able to check it by pressing "M" and typing nano /etc/fstab.

    So if I skip all those errors, I get to a window that says, "Ubuntu is running in low-graphics mode. blah, blah, blah...." I hit okay. Then my options are run Ubuntu in low-graphics-mode for just one session, reconfigure graphics, trouble shoot the error, exit to console login, or restart X.

    I've tried running in low graphics mode, but it tells me "Stand by one minute while the display restarts..." Then the screen flickers and I'm back at the Ubuntu 10.10 screen with the red / white dot progress bar. It then seems to freeze here. I know I'm not being impatient, because I've left it alone for a few hours, and come back and still frozen. Although, it is responsive to CTL + ALT + DEL which restarts the machine. The same exact thing occurs if I select Restart X or Exit to Console Login.

    Sometimes I've gotten ""An Error Occurred while mounting /swap..." Press S to skip mounting or M for manual recovery." But if I press S or M, nothing happens. It is only responsive to CTL + ALT + DEL.

    If I don't get this fixed ASAP you'll see my face on the back of a milk carton in a couple of weeks. :eek:
  2. falko

    falko Super Moderator Howtoforge Staff

    Have you tried booting into a rescue/live system (e.g. Ubuntu 10.10) and mounting your partitions manually? That might help you to find out what's wrong with them.
  3. jmf346

    jmf346 New Member

    Thanks for the reply Falco! I have tried that and have been able to manually mount them. But I have no idea what to do at that point. What logs would be useful to begin trouble shooting?
  4. falko

    falko Super Moderator Howtoforge Staff

    The logs are in the /var/log/ directory of the hard drive. Don't mix this up with the /var/log/ directory of the live system! If you've mounted /var/log/ to /mnt, for example, the logs are in /mnt/var/log.

    You can also chroot yourself to the /mnt directory:
    chroot /mnt
    Then you can run commands as if you were on the original system, e.g.
    to find out if there are errors during the boot process.

Share This Page