Urgent Pls -Accessing FTP site using FTP Clients s/w on XP machines.

Discussion in 'HOWTO-Related Questions' started by munirg2003, Jun 22, 2007.

  1. munirg2003

    munirg2003 New Member

    My scenario is: -

    - I have xp client machines with proper proxy settings. Internet is running well. Plus client ftp software i.e., Ws-ftp95 or FileZilla.

    - I have Linux ES-4 with Squid 2.6-13 stable installed by me with customized options i.e; --enable-arp-acl and --enable-delay-pools etc etc. The same server has two Ethernet Interfaces i.e., Eth0 (Connected configured to my internal LAN) and Eth1 (Connected to External broadband WAN)

    Now we want to upload our files from client machines using ftp client browsers mentioned above but it is not connecting to site. Eventually i have to sit on server and have to use ftp command line command to upload data and it uploads perfectly after verifying user name and password. Even i tried this as you told me but all in vain: -

    #iptables -A INPUT -s myLanNetID -p tcp --dport 20 -j ACCEPT
    #iptables -A INPUT -s myLanNetID -p tcp --dport 21 -j ACCEPT

    #iptables -A OUTPUT -d WAN-IP -p tcp --sport 20 -j ACCEPT
    #iptables -A OUTPUT -d WAN-IP -p tcp --sport 21 -j ACCEPT

    #iptables -A FORWARD -s myLanNetID -d WAN-IP -p tcp --dport 20 -j ACCEPT
    #iptables -A FORWARD -s myLanNetID -d WAN-IP -p tcp --dport 21 -j ACCEPT

    #service iptables save

    - Please let me know the correct solution in easy steps.

    Best Regards
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client(s)?
  3. munirg2003

    munirg2003 New Member

    Dear Falko

    Yes dear Falko.

    I have tried both active and passive modes both in squid and in ws_ftp95 ftp browser but not worked.

Share This Page