Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (mdv2010)

Discussion in 'HOWTO-Related Questions' started by taylor-made, Jul 20, 2010.

  1. taylor-made

    taylor-made New Member

    I'm sure this is probably a simple fix, but darned if I can find it on my own. Here are the details:

    I followed the instructions in falko's most excellent Virtual Users And Domains with Postfix, Courier, MySQL, And SquirrelMail (Mandriva 2010.0 x86_64) guide to upgrade my server from Mandriva 2008 (which had been installed according to the earlier Mandriva 2008 flavor of the same guide), making suitable changes to installed package names to account for using the 32-bit version on my server (well, it's not a 64-bit cpu...) of course. The MySQL database for this installation is a restored backup (from an exported .sql file) of the database from the old installation, and all of its data is in good order. Essentially I'm migrating a server to a new OS, but starting with a clean install and restoring backed-up databases where needed.

    Everything seems to work satisfactorily except this: e-mail sent to addresses in the forwardings table get bounced. The error message from the log is as follows:

    After digging around through this forum for a while, I tried one suggestion and commented out the receive_override_options = no_address_mappings line in and reloaded Postfix. Then I sent another test e-mail to myself, with the following result:

    Voila! Forwarding now works! But...none of my e-mails seem to have amavis/spamassassin/clamav headers written into them by the server. Now, the guide said that the line I commented out had to do with getting e-mails processed through amavis, so I figured this is probably a problem with amavis. Checking on amavis with the start script got this result:

    So, I went through all of the steps for setting up amavis again, just to double-check the files and make sure I didn't have any typos. I even went so far as to cat > /dev/null the contents of amavisd.conf and then paste the entirety of falko's configuration text into it (from the text window near the end of page 3), then making the necessary database username and password changes. :cool: I also repeated the steps for initializing Razor and Pyzor (with no errors reported). After that, I deleted the amavisd pid files and restarted amavisd. This time it stayed running:

    After that, I uncommented the receive_overrides_options line from, restarted Postfix and sent another test e-mail. Same problem: the test e-mail bounced with the exact same logged error quoted above.

    I'm stumped! Does anyone have any suggestions on where I may have screwed up? I'm sure there's a mistake I've made here somewhere, but darned if I can find it! I'd sure appreciate a bit of sage advice right about now.
  2. taylor-made

    taylor-made New Member

    Okay, I solved my own problem. I'm not sure where exactly the error was, but I fixed it by stopping Postfix, removing all lines in the #User configurable parameters section of to start from scratch, then copy/pasting (making the required hostname changes) all of the postconf -e commands from the howto all over again, and starting Postfix back up. No more bounced e-mails and my e-mail headers indicate that amavis is busy scanning for viruses and spam.

    Color me happy! :D

Share This Page