WARNING: Forcing protocol to TCP due to option specification. Please explicitly state intended pro

Discussion in 'Installation/Configuration' started by Goedendag, Sep 7, 2021.

  1. Goedendag

    Goedendag New Member

    Dear all, I get following error upon trying to update ISPConfig 3 on my server. I find absolutely nothing about it online except one pull request on someone's gitmemory. Please help!

    Operating System: Ubuntu 20.04.3 LTS (Focal Fossa)

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    Checking ISPConfig database .. WARNING: Forcing protocol to TCP due to option specification. Please explicitly state intended protocol.
    OK

    WARNING: Forcing protocol to TCP due to option specification. Please explicitly state intended protocol.
    Starting incremental database update.
    Loading SQL patch file: /tmp/ispconfig3_install/install/sql/incremental/upd_dev_collection.sql
    Reconfigure Permissions in master database? (yes,no) [no]:
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Does that create an actual problem, eg. database connection fails? Or just prints the warning?
     
  3. Goedendag

    Goedendag New Member

    I think it was the cause once of a corrupted one of my apache site files; it said something like <xxxthisshouldbehere WARNING: Forcing protocol to TCP due to option specification. Please explicitly state intended protocol.> which caused the whole thing to break of course. It just amazes me how seemingly almost no one on the Internet has had the same problem.
     
  4. Hbod

    Hbod Member

    FYI: this happened to me after upgrading (by mistake) from MariaDB 10.5 to 10.9 (which looks like to just work perfectly fine with ISPConfig so far).

    Anyway, you need to make sure to add
    bind-address = ::
    to your my.cnf in /etc/mysql/my.cnf

    Afterwards, Multiserver setup worked again and the error has been gone.
     
    till likes this.

Share This Page