Web-FTP Issue

Discussion in 'General' started by nandhu, Aug 15, 2005.

  1. nandhu

    nandhu New Member

    Hi All,

    I'm back with a different problem now.

    I logged in as a Client of a Reseller (in my case nandhu the username) into ISP Config and then clicked on Web-FTP link on the top.

    In the Web Selection area:

    Select Web: I selected a Website in the drop down for username: nandhu
    Username: nandhu (Please note I also tried: web1_nandhu, the default that appreared int he username when selected the website).
    Password: <appropriate password>

    And upon clicking the Selection button, I got the following error:

    The following error ocurred:

    Could not connect as user web1_nandhu

    Next >> (this is an hyper link)

    But at the same time I also got the 3 toolbar buttons
    File Upload, New Folder and FTP Logout.

    When I clicked on FTP Logout, I get back to the Web Selection page.

    But when I click on the Next hyper link, I'm thrown out of the ISP-Config back to ISP Config login screen.

    If I click on File Upload or New Folder, I get the same error page back with the Next hyper link displayed.

    I'm sure my proftp-d is running. I would like to mention that I have not altered any configuration, I just installed as told in the Falko's instructions and left it at that state.

    ISP Config while installing did pickup the only FTP Daemon (PROFTPD) correctly.

    So, please help me in getting this working correctly.

    Please note: My firewall for port 21 is not opened (BT Voyager 240 is my h/w router+firewall+adsl modem). But then I think that should not matter as it is a web-based ftp. Correct me if I'm wrong in my assumption.

    Many thanks for all your time and efforts.

    - Nanda.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no difference betweeen the ISPConfig webbased FTP and a normal FTP Client, both are using the installed FTP-Server. You have to open your firewall for FTP, at least for localhost.

    When the username web1_nandhu is presented by ISPConfig, this is the correct username for FTP Logins.

    Can you connect with an normal FTP-Client?
  3. nandhu

    nandhu New Member

  4. nandhu

    nandhu New Member

    Thanks Till.

    I'll try with normal ftp-client this evening and will update this area.
    I'll also open up the port 21.

    - Nanda.
  5. nandhu

    nandhu New Member

    Hi Timme,

    I tried smartftp free ftp client and i was able to login.

    see the log extract from smart ftp below
    when i used web-ftp and tried to login with the same credentials, i tailed the /var/log/messages and get to see the following;-

    My netstat -tap for proftpd shows the following:-

    Also my /etc/pam.d/ftp looks like the following:

    Any idea as how I could resolve it


    - Nanda.
    Last edited: Aug 18, 2005
  6. falko

    falko Super Moderator Howtoforge Staff

    Can you put this into /etc/pam.d/ftp (make a copy of your current file before):

    auth    required        pam_unix.so     nullok
    account required        pam_unix.so
    session required        pam_unix.so
    Then restart Proftpd.
  7. nandhu

    nandhu New Member

    Hi Falko,

    I tried that and even with the modified /etc/pam.d/ftp all I get can get to work is only SmartFTP, not Web-FTP.

    I tried SmartFTP with a System user.

    I tried Web-FTP with the user whose username/password is same as System user.

    If you manage to login into my server, you could see that I've two files now in /etc/pam.d/

    one is: ftp.original and ftp.as.in.falkotimme

    Currently I've copied the /etc/pam.d/ftp.original onto /etc/pam.d/ftp

    I'm still confused as the error message does not tell us why the user could not login.

    Thanks for your help.

  8. lpaseen

    lpaseen New Member

    me too

    Did you get it to work? how?

    I did install ISPConfig on a debian system (which was done accirding to the "perfect install" guide for 3.1) and have the same issue. Web ftp doesn't work get two boxes with info that the lign failed. doing ftp directly to the server works.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked the FTP checkbox in the settings of this website?
    Does other externel FTP clients (e.g. WS_FTP) work?
  10. lpaseen

    lpaseen New Member

    I did check the ftp check box
    I can do ftp from another server to this server and login with the same credentials that fails when in web-ftp mode
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your proftpd.conf if your FTP Server listens also on localhost (IP
  12. lpaseen

    lpaseen New Member

    Some environment background; I have a internal network with several computers. Normally I work on my desktop and this setup is on a lab system
    Between desktop and labsystem it's nothing more then the switch and I don't use iptables on any of this servers.

    I tried
    ftp to localhost on the lab system, no problem
    ftp from my desktop to lab, no problem
    login to ISPConfig (https://clu217.intra.techwiz.ca:81/ ) as client I setup.
    Here I get the small navigation menue with one site I created earlier​
    click on Web-FTP
    Left shows a globe and "/", right shows "Select Web" (with only one choice), username, password and the "Selection" button.​
    I enter same username and password I used in the ftp tests earlier and it fails as described earlier in this thread (Can not connect but with the icons there)​

    except this time! I done the steps above several times and redid them now just to make sure of the exact output but now it worked. I haven't restarted anything on the server (but I did restart my browser). My only guess is that I had tried wrong password to many times and somehow locked it out before, or the browser restart cleared the cookies or something.

    Since I already written all this I'm posting it and keep on testing, but for the moment it seems to work.

Share This Page