Website not working after moving from Apache to Nginx

Discussion in 'Installation/Configuration' started by blax, Jul 24, 2014.

  1. blax

    blax New Member


    I moved a Magento website from an Apache + ISPconfig server to Nginx + ISPconfig (both CentOS 6.5).

    After doing so the website is not working properly: all pages gives 404 error, except for the home-page, on which there are many red lines all over it.

    I think this is caused by some configuration that should be converted from Apache to Nginx, for example the URL rewrite, as the .htaccess file is not recognized by Nginx.

    The error appearing in logs when receiving the 404 error is the following:

    2014/07/24 16:23:28 [error] 26933#0: *63 open() "/var/www/website_name/web/index.php/arceria-e-balestre.html" failed (20: Not a directory), client: x.x.x.x, server: xxxx.xxxx.xx, request: "GET /index.php/arceria-e-balestre.html HTTP/1.1", host: "", referrer: ""

    From the error I understand that the web server is trying to find the physical file, instead of treating it as an URL rewrite.

    Can someone help me to fix these problems?

    Thank you.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. blax

    blax New Member

    I tried to use your Nginx rules but the problem is still the same: only the home page is shown (with strange red lines), and all other pages give 404 error.

    I put the Nginx rules in ISPconfig > Sites > Options tab > nginx Directives.

    I attached some screeshots of how the website is shown.

    Thank you.


    Attached Files:

Share This Page