Weirdest problem ever: ISPconfig admin panel show chunk of php codes

Discussion in 'Installation/Configuration' started by KLSG, Jul 12, 2015.

  1. KLSG

    KLSG New Member

    I am running CentOS 7 LAMP. Everything was new. LAMP and Moodle were installed before ISPConfig.
    I installed ISPconfig 3, everything seemed to be well, but when I tried to access the admin panel at <ip>:8080, I see whole chunk of php codes n plain view of the index.php on the root of my www directory!

    RESOLVED: install mod_fcgid so that ispconfig.vhost would apply the necessary settings upon detection of presence of that module
    Last edited: Jul 12, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not run 2 controlpanels on the same server. To install ispconfig, the server needs to be reinstalled by following the perfect server tutorial.
  3. KLSG

    KLSG New Member

    I uninstalled Ajenti. Btw, my installation of ispconfig was based on the "perfect server tutorial".

    At this point I could see 2 issues:
    1) vhost file not configuring DocumentRoot as /var/www/ispconfig , so that explains why I see Moodle's content instead of ISPconfig's web admin panel content.

    2) Even after configuring DocumentRoot correctly in the vhost file, https<domain>:8080 will hit the correct index.php file in /var/www/ispconfig, but for unknown reason the php code didn't execute. So I see all the php codes in plain view on the browser.

    Note: My Moodle site loads perfectly fine at http<domain> , PHP works fine for my Moodle site
  4. KLSG

    KLSG New Member

    I have figured out the issue myself. Fixed it by installing mod_fcgid
    Apparently the vhost file looks for either mod_fcgid or mpm_itk to apply the necessary settings. But because I had none of those, the DocumentRoot wasn't even applied, which explains why I saw my main site's php file.

    In case you have no idea how to install mod_fcgid, google for this keywords:
    How to install mod_fcgid on CentOS and RHEL
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig vhost file was correct, so you should undo your manual changes. Mod_fcgi is installed in the perfect server guide, so you must have left out some steps. I really recommend that you go again trough the perfect server to ensure tht no other packages are missing. It is likely that you will encounter more issues as ajenti has modified the centos base setup so that ispconfig will most like not work properly.
  6. KLSG

    KLSG New Member

    Thanks, but I wouldn't risk reinstall my core applications like mariadb, apache, php and moodle. The former 3 were preinstalled in the OS image, so I assumed the server was still aligned to the perfect server setup.

    At worst I'm gonna give up using ISPconfig... I guess it's CLI ftw till a solid free GUI surfaces. It sucks to be expected to pay for Plesk/Cpanel for a higher price than the VPS account itself

    Nevertheless, thank you for your help, till.

    P.S: Is there any ready-to-go OS image iso? I think that'd save everyone a lot of time isn't it? Just a thought
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    All perfect server guides are available as images for vmware at howtoforge and there is also a ISPConfig auto installer for Debian and Ubuntu.

    Plesk wont work as well on a server where you have another panel and sites outside of plesk. So you would have to reinstall for a clean plesk install in the same way that you would hav to do for a Clean ISPConfig install. The same applies for cpanel, directadmin and all other hosting panels as each of them has its own setup that cant be mixed with the setup of other panels, so nothing ISPConfig specific here.

Share This Page