Where to Install

Discussion in 'Installation/Configuration' started by latcarf, Aug 10, 2005.

  1. latcarf

    latcarf New Member

    I reinstalled FC4 and then proceeded to install ISPConfig but it experienced problems at the end
    Warning: main(config.inc.php): failed to open stream: No such file or directory in /home/install_ispconfig/install.php on line 624
    Warning: main(): Failed opening 'config.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/install_ispconfig/install.php on line 624
    Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /home/install_ispconfig/install.php on line 634
    Could not connect to db
    Restarting some services...
    ./setup2: line 831: [: ==: unary operator expected
    ./setup2: line 849: /etc/rc.d/init.d/ispconfig_server: No such file or directory
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Despite the last line it won't go to the login page. It worked on the previous install but I think I may have installed it from the wrong directory this time.

    What directory should ISPConfig be installed from/on?

    Will #apt-get remove ispconfig# remove the current intall?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can install it from any directory, as long as you first enter the install_ispconfig directory and then start the setup like this
    from inside the directory.

    I assume you got this error because you tried to install ISPConfig before and that install was interrupted and you dont have extracted the installer tar.gz again.

    To uninstall ISPConfig, run the following script:

    If the uninstall script is not there, you can delete the following directorys manually:

    rm -rf /root/ispconfig
    rm -rf /home/admispconfig
  3. falko

    falko Super Moderator Howtoforge Staff

    Yes, don't do a second install from the same install_ispconfig directory. Delete this install_ispconfig directory, and then you _must_ unpack the ISPConfig tar.gz again. Then go to the new install_ispconfig and run

  4. latcarf

    latcarf New Member

    thanks till, falko...

  5. latcarf

    latcarf New Member

    My ISPConfig keeps stopping at the mySQL login :( ;
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    ERROR: The provided MySQL password is wrong! The installation routine stops here!
    Should my mySQL user be "server1" since that is the subdomain name for this computer?

    I don't recall setting a user name specific to MySQL when Ioaded it. I did write down the passwords, keys, passes, and challenges so I am sure I have that part correct.

    I enetered localhost for MySQL server: and root for MySQL user;. When I log into the console as root it is shows as [root@server1].


    p.s. can I use #mysqladmin -u root password mypassword
    to reset the password just in case...
    Last edited: Aug 11, 2005
  6. falko

    falko Super Moderator Howtoforge Staff

    User root should be correct, but you need a password for the MySQL user root (which is different from the system user root!).

    mysqladmin -u root password mypassword
    works only if you haven't set a password before. Otherwise it's
    mysqladmin -u root -pcurrentpassword password mypassword
    so you need your password again...
  7. latcarf

    latcarf New Member

    well I wrote it down and it is familar to me but it does not seem to be working :confused: I did a restart on mysqld and it stopped ok but starting timed out and failed. Is it possible to uninstall MySQL and reinstall?
  8. latcarf

    latcarf New Member

    p.s. the command line to uninstall would help! Then I should be able to reinstall using the HowTo, correct?
  9. falko

    falko Super Moderator Howtoforge Staff

    You could try
    yum remove mysql mysql-devel mysql-server
    and then
    yum install mysql mysql-devel mysql-server
    but I don't know if this will work for you... :confused:
  10. latcarf

    latcarf New Member

    well that uninstalled it, at least 4 components as the console stated. I reinstalled but got the same error when I used

    # mysqladmin -u root password ********

    got this

    # Access denied for user 'root'@'localhost' (using password: NO)

    Difference is (using password; NO) said (using password; YES) when I was installing ISPConfig.

    I am now doing a fresh install of FC4. If all else fails I will be very proficient at installing FC4 :D

    Just to be sure, when using The Perfect Install of FC4 HowTo and we enter

    # mysqladmin -u root password yourrootsqlpassword

    the only thing we need to change is "yourrootsqlpassword"?

    "localhost" will always work for mySQL server name, and

    "root" will always work for mySQL user on a fresh install of FC4 and ISPConfig?
  11. falko

    falko Super Moderator Howtoforge Staff

    That's right! :)
  12. latcarf

    latcarf New Member

    I guess I am now proficient in the insatllation because everything went perfect to include the install of ISPConfig.

    But when I try to log into the ISPConfig page it keeps timing out. Browser states it is looking then connecting but it just keeps on connecting. Everything okay on that end with ISPConfig?

    By the way thanks for the help along the way. It is great to have a place where they actually give you timely and comprehensive answers. I hope us newbs don't wear you and till out! ;)

    I found a procedure for mySQL password recovery and resetting AFTER I started reinstalling FC4. I can still post it if you don't mind me referencing where it came from. May come in handy for someone else.
  13. latcarf

    latcarf New Member

    follow up

    I did some searching and found some info....

    I ran nestat -tap and it shows listening on port 81 for ISPConfig

    then I used www.myserverIP.de:81 and it took me to the login page. I logged in but when I try to select anything the browser indicates "transferring from myIP" but the page never finishes, in fact according to my router nothing is moving in or out during this time.

    I have a Belkin F5D7230-4 (cabled) does port 81 need to be opened? TCP and UPD? What would the description be, ISPConfig or www.mydomain.de?
  14. falko

    falko Super Moderator Howtoforge Staff

    When you try to connect to ISPConfig, you _must_ use the hostname and domain you used during installation. E.g., when you entered server1 as hostname and example.com as domain, then you have to type http(s)://server1.example.com:81 in the browser's address bar. And server1.example.com must resolve to your ISPConfig system!
  15. latcarf

    latcarf New Member

    aahhh... then that may be the problem I think.

    My computer hostname is "server1", and

    the ISPConfig hostname I entered during install was "www".

    Neither www or server1.thefractalfarm.net:81 connect to the ISPC home page.

    I have the ISPConfig doc printed out. I'll dig in and see what I can find about changing the hostname.

  16. falko

    falko Super Moderator Howtoforge Staff

    You can change that in /home/admispconfig/ispconfig/lib/config.inc.php.
  17. latcarf

    latcarf New Member

    I changed this

    $go_info["server"]["server_url"] = "http://www.thefractalfarm.net:81";

    to this

    $go_info["server"]["server_url"] = "http://server1.thefractalfarm.net:81";

    And it still will not connect :confused: my server IP still gets me there and I can login.

    Once I log in I can see all the selections such as Management, ISP Management, DNS Management an so on and I can see all of the sub menu selections on the left side but the right side never finishes generating. My browser indicates "Transferring data from but the router lights at that point indicate otherwise.

    I attached the config.inc.php file, maybe you can see something I don't understand in it.
    Last edited by a moderator: Aug 12, 2005
  18. falko

    falko Super Moderator Howtoforge Staff

    Do you have a DNS record for server1.thefractalfarm.net that points to your ISPConfig box? :D
    As far as I can see you're in a local network (, and I guess that server1.thefractalfarm.net resolves to a local IP address. You need to change this, or you can enter your IP address in /home/admispconfig/ispconfig/lib/config.inc.php:

    $go_info["server"]["server_url"] = "";
  19. latcarf

    latcarf New Member

    where did you see local network

    After reloading FC4 and ISPConfig the other day I had forgotten to insert my named and zone files back in. :rolleyes: Did that and fixed the can of worms that opened when I loaded them and restarted named.

    server1 and are the same. Also the same box where I have my ISPConfig, http, ftp, and mail. I am running in views so I attached my internal and external zone files. Maybe you can see if I am missing something. When I changed the hostname in the config.inc.php did I need to restart anything?

    Attached Files:

  20. falko

    falko Super Moderator Howtoforge Staff

    Is the name server where you created server1.thefractalfarm.net authoritative? I mean if the authoritative name server for thefractalfarm.net is, and you create the record for server1.thefractalfarm.net on the nameserver, then this won't work, because every time you type server1.thefractalfarm.net into your browser's address bar, then is going to be asked, and it doesn't know server1.thefractalfarm.net...

    You don't need to restart anything when you change config.inc.php. You might have to re-login into ISPConfig for the changes to take effect, but that's all.

Share This Page