whitelist an email address

Discussion in 'General' started by florix.net, Oct 27, 2022.

  1. florix.net

    florix.net Member

    Centos 7, ISPCONFIG 3.1..15p2,

    One of my client not receiving email from one particular domain
    [email protected]

    I have added this email address in EMAIL->SPAMFILTER->WHITELIST
    also the clients domain spam policy is WANTS ALL THE SPAM, and in email account, MAIL FILTER,
    "Move Spam Emails to Junk directory" is also not checked.

    still all the emails from [email protected] goto spam folder, I have to login to webmail and then move all junk to inbox in order to get his emails.

    how can I fix this?

     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check mail headers to see why this happens and mail.log and also the .sieve filter file of the mail account. Such behavior can be caused by an email client which connects to the server.
     
    pyte likes this.
  3. pyte

    pyte Active Member HowtoForge Supporter

    If you are using rspamd, you can search the rspamd.log for the mail in question and see what happened with the mail. But as till already mentioned this is likely a client or mailbox rule (.sieve) that sorts the mail automatically into the Junk folder.

    Code:
    grep [email protected] /var/log/rspamd/rspamd.log
     
  4. florix.net

    florix.net Member

    Sieve file is empty.


    require ["fileinto", "regex", "date", "relational", "vacation"];





    keep;
     
  5. florix.net

    florix.net Member

    mail goes to server Junk folder
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Your .sieve file is empty, so it is not your server that moves the mail files to junk. It must be a mail client connecting to this mailbox.
     
  7. florix.net

    florix.net Member

    they use outlook, can a local client move mails to Junk via pop?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No. But maybe they do not just use Outlook but also connect to it with their mobile device which then moves the emails. The only way that ISPConfig is able to move that mail to junk is via .sieve and you verified that there is no rule to do so, so what you see must be caused by something else. You can e.g. check the mail.log for connects to this mailbox to see if there are any IMAP connects.
     
  9. florix.net

    florix.net Member

    i have disconnected all apps which use this email address. only emclient configured as pop3 use this email id.

    Still all emails goto junk. when I see headers, I dont see any marking in headers .. like spam score etc.
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What do em client logs show for the messages moved to Junk?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    And you might want to change the password of the account and take care to set it only in the pop3-connected client.
     
  12. florix.net

    florix.net Member

    changing password is great idea, how do I set only pop3 connected?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    See the options of the mailbox, there is a checkbox to deactivate IMAP.
     
  14. florix.net

    florix.net Member

    That worked like a charm .. so much headache over this. Thank you Till and Taleman for your quick help.
    for me next challage is setup server SSL for IMAP and POP3.

    i have used name like trinity.fx.net for my server and hosted many domains over it.

    can you point me to some tutorial where it explains how to use valid certificate for my server?
     
  15. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you use ISPConfig, it should set up certificate for e-mail server automatically. Are you sure it is not working?
    There is a problem if there is website with same name as FQDN of the server, then certificate is not copied for e-mail server use. Or was this only if acme.sh is the LE client? Search old discussions, recent on this forum. My signature has link to e-mail setup tutorial.
    You should maybe have created a new thread, certificate problem has nothing to do with this thread.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Like @Taleman explained, it is set up automatically with a valid cert.
     

Share This Page