WhiteList error rule

Discussion in 'General' started by andresgt2000, Jul 16, 2014.

  1. andresgt2000

    andresgt2000 Member

    I have a problem in the mail whitelist of the infrastructure ISPConfig 3.

    As you can see in the attached, the client added a global rule for the domain in the whitelist and it seems fine, but was assigned to the wrong mail server.

    The problem is that the domain is assigned to work on the mail server mail2.domain.com.

    When I create a record for a specific account if assigned to the correct mail server.

    How can I resolve this error? because this rule is not running on the correct server.

    Attached Files:

  2. andresgt2000

    andresgt2000 Member


    I don't receive an answer or commentary about this post.

    Someone know if it is a bug?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Rules get assigned to the server that is selected as default mailserver of the client in its client settings.
  4. andresgt2000

    andresgt2000 Member

    That is correct and the client settings have the correct mail server asigned.

    When you want to make a global rule to apply to the complete domain, the created rule not assign the mail server associated to the client settings.

    This is the behavior that has me confused. :confused:

    Attached Files:

  5. andresgt2000

    andresgt2000 Member


    When I get back from lunch I tell to you what was the problem.
  6. andresgt2000

    andresgt2000 Member

    What happened and how was solved.

    According to Till's response:

    I went to the mail domain problems. We take the client leaving the field blank and saved the change.

    Then we returned to assign the client to the domain. Then we tried to generate a whitelist rule for the domain in general and it was generated correctly.

    That's what I think happened:

    1. When the customer is generated, is assigned the server bad.
    2. The client was assigned to the mail domain; but assigned the correct mail server.
    3. The username was renamed but the server was still misassigned.
    4. The server is correctly assigned to the client.
    5. For some reason the client information does not refresh properly in the domain.

    Why do I think this happened?

    When I moved the client and I returned to assign; change the position of the domain in the list and I have the impression that the name of the client was the pre-renowned.

    I do not know if this makes sense; but the incident was resolved. :D

Share This Page