Wierd file and folder permission problem.

Discussion in 'Installation/Configuration' started by Code5, Jul 23, 2008.

  1. Code5

    Code5 New Member

    Hi all, I have a problem with loosing permission to delete or change permissions of self created files and folders.

    When i run a php script that uses fopen command to create files and folders, the user it is done under looses permission to delete that self created folder or file.

    e.g. the php script creates a few directories and files generated from the install script of the php application.

    e.g. /logs

    I then also get an error saying fopen cannot open stream failed to open such a file etc etc.

    So when i go to the files and folders using ftp i can see the folders but no files are generated as it says it needs permission "fopen"

    After trying this php application a few times i sacked it off and just wanted to delete the folders that had been "self generated" and it says in ispconfig web-ftp "The directory must be empty and you must own write permissions"

    so i tried deleting the folders and files within the directory and it says the same to the lowest directory level.

    I hope you can understand what i mean. Ive waffled around the houses a bit.

    Thanks for any help here.

    One other thing, would i be better of with a different distribution of Linux as im using Ubuntu Server 8?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to reconfigure php to run e.g. with suphp if the files and folders that were generated by the php file shall have the web admin as owner and not the apache user.
  3. Code5

    Code5 New Member

    How to?

    Cheers, but as im a noob, how do i go about doing that?

    What is the command syntax?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page