Wordpress installation and php files being non-responsive

Discussion in 'Installation/Configuration' started by Sheshman, May 15, 2020.

  1. Sheshman

    Sheshman Member

    Using latest version of ISP config on Ubuntu 18.04.4 LTS(virtual machine worksunder oracle vm), first of all thanks for this system it makes things easier rookies like me and giving chance to self-educate about linux systems.
    Yesterday i've installed through https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/ without any problem, i've defined client,web site,ftp account,database account and database, after that i've changed my test domain's NS records to my tets server ip address and in one hour it started to publish from my server :)

    My problem is about php scripts, when i create a php file which only includes print "hi"; or phpinfo(); it works fine, but when i try to install wordpress first two steps works fine when it tries to connect MySQL database on the server chrome's loading icon(on the tab) is starting to circle and even after 20 minutes it doesn't go to next step, sometimes it passes database step so fast and getting stuck at next step,it's like it's randomly stucking in any step.

    Other strange thing is if i upload an empty php file,i mean file's extension is .php but there is no php code in it, only basic html tags, then server does the same thing, chrome's loading icon keep spinning like 10-15 minutes and page is not loading, but if i add <?php print "hi"; ?> to same file and refresh then it loads the page and showing the content.
    My web site setting as attached, am i doing something wrong?

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the error.log of that website for errors, you can find the log in the 'log' folder of the site.
    Sheshman likes this.
  3. Sheshman

    Sheshman Member

    Hi Till,
    thanks for the heads up about logs(i'm very rookie about linux systems so please forgive my lack of experience to search what in where),
    my log out put is;
    [Fri May 15 04:15:44.267102 2020] [proxy_fcgi:error] [pid 23921] [client] AH01071: Got error 'Primary script unknown\n'
    [Fri May 15 08:33:21.985696 2020] [autoindex:error] [pid 1994] (13)Permission denied: [client] AH01275: Can't open directory for index: /var/www/clients/client1/web3/web/
    [Fri May 15 08:51:31.779872 2020] [php7:notice] [pid 3356] [client] WordPress database error Unknown column 'wp_' in 'field list' for query SELECT wp_, referer: http://mydomain.com/wp-admin/setup-config.php?step=1
    [Fri May 15 09:10:20.643934 2020] [proxy_fcgi:error] [pid 10301] [client] AH01071: Got error 'PHP message: WordPress database error Unknown column 'wp_' in 'field list' for query SELECT wp_\n', referer: http://mydomain.com/wp-admin/setup-config.php?step=1
    i think problem is about MySQL tables, somehow wordpress installation couldn't create tables or having trouble to reach to tables?
  4. Sheshman

    Sheshman Member

    ok,i think mysql problem fixed,the problem was i was using same user for both database user and read-only user,when i remove the read-only user, php files started to connect to mysql without any problem.

    Now i'm receiving this error :
    [Fri May 15 10:02:33.107868 2020] [proxy_fcgi:error] [pid 12849] [client] AH01071: Got error 'PHP message: PHP Warning: require(/var/www/clients/client1/web3/web/wp-content/themes/twentynineteen/inc/helper-functions.php): failed to open stream: No such file or directory in /var/www/clients/client1/web3/web/wp-content/themes/twentynineteen/functions.php on line 310\nPHP message: PHP Fatal error: require(): Failed opening required '/var/www/clients/client1/web3/web/wp-content/themes/twentynineteen/inc/helper-functions.php' (include_path='.:/usr/share/php') in /var/www/clients/client1/web3/web/wp-content/themes/twentynineteen/functions.php on line 310\n'
    and it gives me blank page on browser. Tried with two different wordpress versions but result is the same.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if there are WordPress files missing from Twentyninteen theme.
  6. Sheshman

    Sheshman Member

    yeah seems like it, but the strange thing is when i install same wordpress to my localhost (xampp+windows) it works.
  7. Sheshman

    Sheshman Member

    i believe i've solved the problem, what i did was;
    -connect to server through SFTP
    -go to wp-content->themes
    -rename twentynineteen to twentynineteenxxxx (so this will force wordpress to use another theme )
    and finally i can login to admin panel,i still don't have any idea why it works on localhost but not working on ispconfig, can that happen because my ispconfig works on Oracle VM as virtual machine?

    Also realised that if i try to open my website via chrome, that loading icon spinning problem happens, but if i use firefox or opera it works fast and without any problem, i think my chrome is broken, thanks for your help and patience to my silliness :)
    Last edited: May 15, 2020

Share This Page