Wrong permissions on postfix

Discussion in 'Server Operation' started by Richard Franklin, Apr 5, 2016.

  1. Richard Franklin

    Richard Franklin New Member

    I have a problem with a running Debian squeeze installation of Ispconfig3 and postfix courier setup.
    The problem occured when i mistyped "chown -R user /" when i figured it was too late, then tried to "chown -R root" and perhaps got some things better, but some didn't, now i've already fixed one site, but the main problem that's getting my head into water is e-mail. I had configured postfix with courier and the scenario is for multiple vhosts on this email server, what happens is that at some point i got a permission issue, did "postfix check" and tried to fix the correct permissions, still not clean but imapd is rejecting logins all the time, now is there any sort of "wipe" everything related to email and get back to a first time setup of the email configuration step of ex. "Perfect server ISPCONFIG 3 Debian...."???
    If someone could give a hand i would be thankful.
  2. Hello,
    My first tip is to reinstall the server, because there are system users to see who have permissions on some directories such as / usr, / var ... A way out would be to seek these permissions via script of a new server and reapply the current server. So that everything is right.
    For applications in ispconfig own, it has an option called "resync Tool". You can try to use it to re-establish the permissions of applications and settings directories.
    Post the results.
    Good luck!

Share This Page